Closed Bug 1054526 Opened 5 years ago Closed 5 years ago

Move LDFLAGS / WIN32_EXE_LDFLAGS out of Makefiles for c-c

Categories

(MailNews Core :: Build Config, defect)

defect
Not set

Tracking

(thunderbird34 fixed)

RESOLVED FIXED
Thunderbird 34.0
Tracking Status
thunderbird34 --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Details

Attachments

(1 file)

This ports the following m-c changes to c-c:
Bug 834645 - move -STACK parameter to config.mk
Bug 975733 - Move some LDFLAGS for building executables on Windows to moz.build
Bug 975740 - Port WIN32_EXE_LDFLAGS to moz.build

and additionally for SM:
Bug 683127 part 8 - Allow to load Elf files from a Zip archive
Attachment #8473912 - Flags: review?(Pidgeot18)
Comment on attachment 8473912 [details] [diff] [review]
Port the changes [Checked in: Comment 2]

Review of attachment 8473912 [details] [diff] [review]:
-----------------------------------------------------------------

Maybe we could/should write a template for the main binary ... :-P
Attachment #8473912 - Flags: review?(Pidgeot18) → review+
Comment on attachment 8473912 [details] [diff] [review]
Port the changes [Checked in: Comment 2]

http://hg.mozilla.org/comm-central/rev/45acc039fecd
Attachment #8473912 - Attachment description: Port the changes → Port the changes [Checked in: Comment 2]
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 34.0
Duplicate of this bug: 1037376
You need to log in before you can comment on or make changes to this bug.