Closed Bug 1054574 Opened 8 years ago Closed 8 years ago

[B2G][2.0][Calendar] Overscroll effect is not elastic on the event list.

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1035598
blocking-b2g -
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- unaffected

People

(Reporter: ychung, Unassigned)

References

()

Details

(Whiteboard: [2.0-exploratory])

Attachments

(1 file)

Description:
In the Calendar app, the overscroll effect on the top of the event list is not elastic.

Repro Steps:
1) Update a Flame to BuildID: 20140815000200.
2) Open the Calendar app.
3) Select the '+' icon.
4) Enter the title, and select 'save'.
5) Create 2 more events on the same day.
6) On the Month view, try to overscroll on the event list with the 3 created items.

Actual:
The oversroll on the top of the list is not elastic. It only zooms in with the top part fixed.

Expected:
The overscroll effect is elastic.

Note: 
The bottom part of the list overscrolls properly with the elastic effect.

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319 mb)
Build ID: 20140815000200
Gaia: 295c7f50707372e5af6d8e83148d2d970076dfd6
Gecko: 879c5208084f
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro Frequency: 100%
Link to failed test case: N/A
See attached: logcat, video
http://youtu.be/kWF_sI_s7Cg
This issue also reproduces on Buri 2.0:

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140815003001
Gaia: 295c7f50707372e5af6d8e83148d2d970076dfd6
Gecko: 879c5208084f
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The overscroll effect is not elastic on the top part of the event list.

===============================================
This issue does NOT reproduce on Flame 2.1 and Buri 2.1:

Flame 2.1

Environmental Variables:
Device: Flame Master (319 mb)
Build ID: 20140815040204
Gaia: 9979fccc6321be72cd17370f3a20c65bc376af33
Gecko: c9f8cc9ce89c
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140815103005
Gaia: d0d773c277a9105288ee35da2121f4ae62709be8
Gecko: e05ba2d89374
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The overscroll effect is elastic.

===============================================
This issue is not reproducible on Flame 1.4:

Flame 1.4

Environmental Variables:
Device: Flame 1.4 (319mb)
Build ID: 20140815063005
Gaia: ab9a57d204c8c06cccc70cb7190da789fe17a3cb
Gecko: 3da3115ee33b
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Overscroll is a new feature on 2.0.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]: since this is already fixed on 2.1 we should get a fix window and uplift. Not sure if this was fixed by platform changes or Gaia changes.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Maybe dupe of bug 1035598. Discussed in triage, concluded blocking- for same reasons as there.
blocking-b2g: 2.0? → -
Based on the video, this is almost certainly a dupe of bug 1035598 (which is fixed for 2.1 and for which 2.0 uplift was just denied).
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1035598
You need to log in before you can comment on or make changes to this bug.