Closed Bug 1054758 Opened 6 years ago Closed 6 years ago

Implement ES6 Symbol.isConcatSpreadable

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1041586

People

(Reporter: till, Unassigned)

References

()

Details

This entails changing js::array_concat in jsarray.cpp to use the (to-be-introduced) IsConcatSpreadable abstract operation instead of ObjectClassIs in the items loop.
Possibly bug 688852 should land before this changes.  Or, possibly we should just drop that patch/bug entirely and fix that bug here with a self-hosted version.  :-\
Blocks: 1119779
No longer blocks: es6
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041586
You need to log in before you can comment on or make changes to this bug.