Fix test test_cost_control_data_alert_mobile after locator change

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Bebe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Looks like some locators for this test have changed after:

Bug 1016816 - [CostControl] Update to use gaia-header

Please update and fix the test


TEST-UNEXPECTED-ERROR | test_cost_control_data_alert_mobile.py TestCostControlDataAlertMobile.test_cost_control_data_alert_mobile | NoSuchElementException: NoSuchElementException: Unable to locate element: //ul[preceding-sibling::header[@id='data-usage-settings']]/li[2]/label
05:34:41 Traceback (most recent call last):
05:34:41   File "/var/jenkins/1/workspace/flame.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/marionette_test.py", line 171, in run
05:34:41     testMethod()
05:34:41   File "/var/jenkins/1/workspace/flame.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/cost_control/test_cost_control_data_alert_mobile.py", line 35, in test_cost_control_data_alert_mobile
05:34:41     settings.toggle_data_alert_switch(True)
05:34:41   File "/var/jenkins/1/workspace/flame.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/cost_control/regions/settings.py", line 37, in toggle_data_alert_switch
05:34:41     label = self.marionette.find_element(*self._data_alert_label_locator)
05:34:41   File "/var/jenkins/1/workspace/flame.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/marionette.py", line 1274, in find_element
05:34:41     response = self._send_message('findElement', 'value', **kwargs)
05:34:41   File "/var/jenkins/1/workspace/flame.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/decorators.py", line 35, in _
05:34:41     return func(*args, **kwargs)
05:34:41   File "/var/jenkins/1/workspace/flame.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/marionette.py", line 634, in _send_message
05:34:41     self._handle_error(response)
05:34:41   File "/var/jenkins/1/workspace/flame.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.2-py2.7.egg/marionette/marionette.py", line 668, in _handle_error
05:34:41     raise errors.NoSuchElementException(message=message, status=status, stacktrace=stacktrace)
(Reporter)

Comment 1

4 years ago
Created attachment 8474544 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22994
Attachment #8474544 - Flags: review?(zcampbell)
Attachment #8474544 - Flags: review?(robert.chira)
Duplicate of this bug: 1054551
Attachment #8474544 - Flags: review?(robert.chira) → review+

Comment 3

4 years ago
Comment on attachment 8474544 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22994

r+
Attachment #8474544 - Flags: review?(zcampbell) → review+

Comment 4

4 years ago
Merged:
https://github.com/mozilla-b2g/gaia/commit/de7aa7e26f25563d5f9fed8c3f1349edf31df0c1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.