RSS feed validation is dysfunctional for certain feeds.

RESOLVED INVALID

Status

MailNews Core
Feed Reader
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: J.R. Lee, Unassigned)

Tracking

x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Opened RSS subscriptions under my News feed account. Right-clicked account and clicked "Subscribe..." I added the following news feed by Amnesty International:

http://www.amnestyusa.org/rss/action/all/rss.xml

After clicking "Add", the window says the feed is not valid. I clicked "Check validation and retrieve a valid url."


Actual results:

The link opens a new tab in Thunderbird which shows "Feed Validation Service". The page reads "Congratulations! This is a valid RSS feed."


Expected results:

If the feed is in fact, "valid", it should have accepted the feed.

The page offers recommendations for better interoperability with other readers, but I do not control what the RSS feed for any of these news sources. Furthermore, I entered a different feed into the Feed Validation Service, like Mother Jones...

http://www.motherjones.com/rss/blogs_and_articles/feed

...and the same result by the Feed Validation Service renders no interruptions by Thunderbird. Even the feed for Al Jazeera's Opinion feed returns an "invalid" result, but Thunderbird accepts the feed.
(Reporter)

Comment 1

4 years ago
I mentioned Al Jazeera's Opinion feed. For convenience, that feed is below...

http://www.aljazeera.com/Services/Rss/?PostingId=201082874848848938

Comment 2

4 years ago
It's understandable that this seems confusing/contradictory.

(In reply to J.R. Lee from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101
> Firefox/31.0 (Beta/Release)
> Build ID: 20140716183446
> 
> Steps to reproduce:
> 
> Opened RSS subscriptions under my News feed account. Right-clicked account
> and clicked "Subscribe..." I added the following news feed by Amnesty
> International:
> 
> http://www.amnestyusa.org/rss/action/all/rss.xml
> 
> After clicking "Add", the window says the feed is not valid. I clicked
> "Check validation and retrieve a valid url."
> 
> 
> Actual results:
> 
> The link opens a new tab in Thunderbird which shows "Feed Validation
> Service". The page reads "Congratulations! This is a valid RSS feed."
> 
> 
> Expected results:
> 
> If the feed is in fact, "valid", it should have accepted the feed.
> 

The rss2.0 specification states both <title> and <description> are required tags on the feed channel level. Thunderbird is lenient and only requires one; both are missing here.
For this specific case, the w3c validation service is wrong to call it valid.

See here: http://www.rssboard.org/rss-specification#requiredChannelElements

Please notify the publisher to follow the spec and add a <title> at least; this may even be a transient omission in their file, it happens all the time.

> The page offers recommendations for better interoperability with other
> readers, but I do not control what the RSS feed for any of these news
> sources. Furthermore, I entered a different feed into the Feed Validation
> Service, like Mother Jones...
> 
> http://www.motherjones.com/rss/blogs_and_articles/feed
> 
> ...and the same result by the Feed Validation Service renders no
> interruptions by Thunderbird. Even the feed for Al Jazeera's Opinion feed
> returns an "invalid" result, but Thunderbird accepts the feed.

True.  Thunderbird in these cases is much more lenient as the tags flagged as erroneous by the validation service (which certainly are in error per spec) are either optional or not fatal to further processing of the feed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Updated

4 years ago
Component: Untriaged → Feed Reader
Product: Thunderbird → MailNews Core

Updated

4 years ago
Duplicate of this bug: 1090207
You need to log in before you can comment on or make changes to this bug.