Closed Bug 1055203 Opened 7 years ago Closed 7 years ago

[B2G][Calendar] The 'Drawer' button sometimes becomes unresponsive when trying to close the calendar list

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

VERIFIED FIXED
2.1 S3 (29aug)
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified

People

(Reporter: rmead, Assigned: drs)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-flame-test-run-1])

Attachments

(2 files)

Attached file Flame2.1logcat.txt
Description:
After opening the 'Calendar' app, if you tap the 'Drawer' button to open the menu and then tap it again to close it, sometimes the 'Drawer' button will become unresponsive.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140818040201
2) Tap the 'Calendar' app
3) Tap the 'Drawer' icon in upper left corner to open list of calendars.
4) Tap the 'Drawer' icon again to close the list of calendars.
  
Actual:
The 'Drawer' button is unresponsive and the list will not close.
  
Expected: 
The list closes and returns you to the main calendar screen.
  
Flame 2.1 (319mb)

Environmental Variables:
Device: Flame 2.1 Master
BuildID: 20140818040201
Gaia: aa8aace12d65956dd9525da5dac66e0d3b28597f
Gecko: 0aaa2d3d15cc
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
  
Notes:If your having trouble making the 'Drawer' button become unresponsive, try rapidly tapping it.
  
Repro frequency: (2/3, 66%)

See attached: logcat, video clip - http://youtu.be/EGBcMAve08k
The issue does occur on Flame 2.1 (512mb), Buri 2.1, Buri 2.0

When in 'Calendar' app, the 'Drawer' button sometimes becomes unresponsive when trying to close list of calendars.

Flame 2.1 (512mb)

Environmental Variables:
Device: Flame 2.1 Master
BuildID: 20140818040201
Gaia: aa8aace12d65956dd9525da5dac66e0d3b28597f
Gecko: 0aaa2d3d15cc
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.1

Environmental Variables:
Device: Buri 2.1 Master
BuildID: 20140818073016
Gaia: ba1992f2addc5a84afc2eab426f222a6bf2962ba
Gecko: bf27e27c994d
Version: 34.0a1 (2.1 Master)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140818063008
Gaia: 640ce38ca03f1e26a4524ff4215b8b3f7731e2f0
Gecko: 692c93509dc9
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


I could NOT get the issue to reproduce on Flame 2.0 (312mb)


Flame 2.0 (319mb)

Device: Flame 2.0 
BuildID: 20140818000201
Gaia: fb2dd31abed2803eb7ad67eb4c52abb48de1e0f7
Gecko: 09f7a7184c71
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flagging qawanted. Can you guys please look at this and let me know how often the drawer button is unresponsive?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted, regression
Repro Rates for 319mb

Flame 2.1 = 9/10
Flame 2.0 = 0/10
Flame 1.4 = 0/10

Repro Rates for 512mb

Flame 2.1 = 9/10
Flame 2.0 = 0/10
Flame 1.4 = 0/10
Buri  2.1 = 8/10   <---------Only seen when rapidly tapping the drawer button.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
[Blocking Requested - why for this release]: This bug is very easy to encounter in 2.1 Flame using a typical user-path and speed.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
FYI, Bug 1015292 is replacing all the "headers" with web components (and replaced the close button) but I was also able to reproduce the bug even after the patch...
Depends on: 1015292
QA Contact: croesch → pcheng
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140813153056
Gaia: a2219a55145e730e56e09527b40152d68a43b0d9
Gecko: ddda7acf3739
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140813154054
Gaia: a2219a55145e730e56e09527b40152d68a43b0d9
Gecko: c57732433b20
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Gaia is the same so it's a Gecko issue.

Gekco pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ddda7acf3739&tochange=c57732433b20

Possibly caused by Bug 1037066 or Bug 625289 ?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by 1037066 ? Doug can you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(drs+bugzilla)
Component: Gaia::Calendar → Panning and Zooming
Product: Firefox OS → Core
Assignee: nobody → drs+bugzilla
Blocks: 1037066
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(drs+bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1037066
Not a duplicate; fixed via backout.
Resolution: DUPLICATE → FIXED
Target Milestone: --- → 2.1 S3 (29aug)
Duplicate of this bug: 1061426
blocking-b2g: 2.1? → ---
This issue has been verified successfully on Flame2.1.
Reproducing rate: 0/5
See attachment: Verify_Flame_Calendarbutton.mp4

Flame2.1 build version:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.