If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

thunderbird.exe process still around after all windows closed (shutdown hang)

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Thomas Raddatz, Unassigned)

Tracking

(Blocks: 1 bug, {hang, regression})

31 Branch
x86
Windows 7
hang, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB30][has stacktrace])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Updated Thunderbird 24.7.0 to 31.0.
Started and closed Thunderbird.


Actual results:

thunderbird.exe stays active forever and must be killed by hand before Thunderbird can be started again. That happens on each start of Thunderbird (100%).


Expected results:

thunderbird.exe should terminate after all windows have been closed.
(Reporter)

Comment 1

3 years ago
The problem does not happen for Firefox 31.0 and for Thunderbird 24.7.0 and lower. Therefore I downgraded to v24.7.0 for now.

The problem also happens for Thunderbird 32.0b1, installed to a new folder and with a new user profile.

Additional information:

Does Thunderbird hang in safe mode? YES.
Does Thunderbird hang with firewall or antivirus software disabled? YES.
Is gloda indexing enabled or disabled? ENABLED.
Are your mail accounts pop, imap, or a combination? IMAP.
Did the computer go into sleep or hibernate while Thunderbird was running? NO.
Did you change Thunderbird to online or offline status? NO. Always online.
Did you move your (laptop) computer to a different network? NO.
State your operating system and version. State Thunderbird version from Help >
About. Win7 Professional, SP1, current patch level. Thunderbird 31.0.
How often you see the hang (always, rarely, etc)? ALWAYS.
CPU usage - is usage zero, low, high (maxed or pegged), or other? 0 percent.
ldap address book - do you have an ldap directory address book defined? NO.
run netstat (normal start mode):
  TCP    127.0.0.1:59799        Thomas-PC:59800        HERGESTELLT     7036
 [thunderbird.exe]
  TCP    127.0.0.1:59800        Thomas-PC:59799        HERGESTELLT     7036
 [thunderbird.exe]
run netstat (save mode):
  TCP    127.0.0.1:60253        Thomas-PC:60254        HERGESTELLT     6348
 [thunderbird.exe]
  TCP    127.0.0.1:60254        Thomas-PC:60253        HERGESTELLT     6348
 [thunderbird.exe]
If this didn't happen in version 24 and if this end up being a thunderbird issue, then this is a regression.

Could you do us a favor please and determine which b1 beta version between 24 and 31 this first occurs?  You can find them here http://download.cdn.mozilla.net/pub/mozilla.org/thunderbird/releases/

Use binary search to minimize the number of tests you must do - should be only 3-4 tests. For example install beta 28, if fails then install beta 26, if it fails then install beta 25. If 25 fails then we know regression is between 25 and 24. If 25 doesn't fail then regression is between 25 and 26.
Severity: normal → critical
Flags: needinfo?(thomas.raddatz)
Keywords: hang, regression, regressionwindow-wanted
(Reporter)

Comment 3

3 years ago
I checked the following releases twice and the problem first occurs with 31.b1:

31.0.0.5277 - zombie
31.0.0.5298 - zombie
31.0.0.5309 - zombie
24.7.0.5311 - OK
Flags: needinfo?(thomas.raddatz)
(Reporter)

Comment 4

3 years ago
Just to clarify: I started with 31.0 and then installed 31b1, 31b2, 31b3 and eventually went back to 24.7. Then I repeated these steps starting with 31.b1. Everything gets fine after installing 24.7 and the error is back with any of the 31'er release every time.
so 30.0b1 works?
Flags: needinfo?(thomas.raddatz)
(Reporter)

Comment 6

3 years ago
No. It is only 24.7 that works just fine. Each of the 31'er releases ends as a zombie process after closing Thunderbird.
Flags: needinfo?(thomas.raddatz)
But we need to know the first release *between* 24 and 31 that fails. So please test 28.0b1.  
If 28.0b1 works please test 29.0b1 works please test 30.0b1.
If 28.0b1 fails please test 26.0b1 fails please test 25.0b1.
(Reporter)

Comment 8

3 years ago
Sorry. I do not know why I did not understand that immediately.
So here are the results of my tests. Hopefully I did not forget a version again:

24.7.0.5311 - OK
25.0.0.5036 - OK
26.0.0.5065 - OK
27.0.0.5100 (en) - OK
28.0.0.5177 (en) - OK
29.0.0.5227 - OK
30.0.0.5242 - zombie
31.0.0.5277 - zombie
31.0.0.5298 - zombie
31.0.0.5309 - zombie

(en)   = English version
others = German version

Eventually 'Thunderbird Setup 30.0b1.exe' is the first releases that produces the zombie process for me. I double checked that.

Comment 9

3 years ago
Thx for checking. Are you able to pin it down further? Check comm-central builds from http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/
Whiteboard: DUPEME
(In reply to Magnus Melin from comment #9)
> Thx for checking. Are you able to pin it down further? Check comm-central
> builds from http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/

to clarify - you will want to check the builds between 24-Apr-2014 and 	09-May-2014.

But you don't need to check them all, as you did on comment 8 :)  There are roughly 15 builds between 24-Apr-2014 and 09-May-2014 but you should need to test no more than half of them.

Just pick a date half way between one that works and one that doesn't, test it.
repeat - pick a date half way between one that works and one that doesn't, test it.
Flags: needinfo?(thomas.raddatz)
Whiteboard: DUPEME → [regression:TB30][DUPEME]
(Reporter)

Comment 11

3 years ago
I am sorry, but I am not sure what .exe files you want me to download and test. I just finished downloading the .exe files from the following folders (14 items):

24.5.0-candidates
24.6.0-candidates
24.7.0-candidates
27.0b1-candidates
28.0b1-candidates
29.0b1-candidates
30.0b1-candidates

But now I am pretty sure that these .exe files are not the files you want me to test.

All directories with "comm-central" in their names do not contain versions between 29.0.0.5227 (which runs fine) and 30.0.0.5242 (which is the first zombie).

What am I missing?
Flags: needinfo?(thomas.raddatz) → needinfo?(vseerror)
forget what you previously did :)  

you want to use the -comm-central/  builds dated between 24-Apr-2014 and 09-May-2014, such as those in http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2014/05/ specifically thunderbird-32.0a1.en-US.win32.installer.exe in http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2014/05/2014-05-01-03-02-02-comm-central/

A. If the May 1 fails, then go to B below.
If the May 1 works, then pick a date N half way between May 1 and 9, install, test.
- If N fails then pick a date half way between 1 and N, install test, etc
- If N works then pick a date half way between N and 9, install, test, etc
now repeat

B. investigate between 24-Apr-2014 and 30-Apr-2014 using http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2014/04/ - pick a date M half way between and test it.
- If M fails then pick a date half way between 24 and M, install test, etc
- If M works then pick a date half way between M and 30, install, test, etc
now repeat
Flags: needinfo?(vseerror) → needinfo?(thomas.raddatz)
(Reporter)

Comment 13

3 years ago
Based on your detailed description I tested the following versions. Each test ended with a zombie process:

2014/05/2014-05-01-03-02-02-comm-central - 05-01-32.0.0.5234-thunderbird-32.0a1.en-US.win32.installer - zombie
2014/04/2014-04-28-03-02-01-comm-central - 04-28-31.0.0.5231-thunderbird-31.0a1.en-US.win32.installer - zombie
2014/04/2014-04-26-03-02-01-comm-central - 04-26-31.0.0.5229-thunderbird-31.0a1.en-US.win32.installer - zombie
2014/04/2014-04-25-03-02-01-comm-central - 04-25-31.0.0.5228-thunderbird-31.0a1.en-US.win32.installer - zombie
2014/04/2014-04-24-03-02-03-comm-central - 04-24-31.0.0.5227-thunderbird-31.0a1.en-US.win32.installer - zombie
2014/04/2014-04-23-03-02-03-comm-central - 04-23-31.0.0.5226-thunderbird-31.0a1.en-US.win32.installer - zombie

Am I missing something again or shouldn't I better have tested versions between 29.0.0.5227 (OK) and 30.0.0.5242 (zombie)?

For example two more tests with version 30 ended as shown below:

2014/03/2014-03-02-03-02-04-comm-central - 03-02-30.0.0.5174-thunderbird-30.0a1.en-US.win32.installer - zombie
2014/02/2014-02-04-03-02-01-comm-central - 02-04-30.0.0.5148-thunderbird-30.0a1.en-US.win32.installer - OK
Flags: needinfo?(thomas.raddatz)
Toadstools and all other forms of expletives. Yes, I pointed you to the wrong stuff.  my apologies.

You want to test the 30.0a1 series.
begins https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2014/02/2014-02-04-03-02-01-comm-central/
ends https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2014/03/2014-03-18-03-02-03-comm-central/

same procedure - start at the midpoint...
(Reporter)

Comment 15

3 years ago
No problem. Things like that happens.

OK. Additional tests showed that the error first happened with version 30.0.0.5151. (double checked)

2014/03/2014-03-02-03-02-04-comm-central - 03-02-30.0.0.5174-thunderbird-30.0a1.en-US.win32.installer - zombie
2014/02/2014-02-12-03-02-03-comm-central - 02-12-30.0.0.5156-thunderbird-30.0a1.en-US.win32.installer - zombie
2014/02/2014-02-08-03-02-00-comm-central - 02-08-30.0.0.5152-thunderbird-30.0a1.en-US.win32.installer - zombie
2014/02/2014-02-07-03-02-03-comm-central - 02-07-30.0.0.5151-thunderbird-30.0a1.en-US.win32.installer - zombie
2014/02/2014-02-06-03-02-05-comm-central - 02-06-30.0.0.5150-thunderbird-30.0a1.en-US.win32.installer - OK
2014/02/2014-02-04-03-02-01-comm-central - 02-04-30.0.0.5148-thunderbird-30.0a1.en-US.win32.installer - OK
Fantastic work Thomas.  One final test - does it also hang using the latest development build?  https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/

The regression range you defined are these checkins http://hg.mozilla.org/comm-central/pushloghtml?startdate=2014-02-06+03%3A05%3A00&enddate=2014-02-07+04%3A05%3A00
and unfortunately also http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2014-02-06+03%3A05%3A00&enddate=2014-02-07+04%3A05%3A00
Component: Untriaged → General
Flags: needinfo?(thomas.raddatz)
Keywords: regressionwindow-wanted
(Reporter)

Comment 17

3 years ago
Glad to help. Unfortunately the latest nightly build also ends as a zombie process:

/nightly/latest-comm-central - 08-20-34.0.0.5345-thunderbird-34.0a1.en-US.win32.installer - zombie

(double checked against 30.0.0.5150)
Flags: needinfo?(thomas.raddatz)
(In reply to Wayne Mery (:wsmwk) from comment #16)
> The regression range you defined are these checkins
> http://hg.mozilla.org/comm-central/pushloghtml?startdate=2014-02-
> 06+03%3A05%3A00&enddate=2014-02-07+04%3A05%3A00
> and unfortunately also
> http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2014-02-
> 06+03%3A05%3A00&enddate=2014-02-07+04%3A05%3A00

Magnus any in the list stand out for you?  And, did you have something specific in mind regarding the  DUPEME?
Flags: needinfo?(mkmelin+mozilla)

Comment 19

3 years ago
Unfortunately no :(
I'm pretty sure I saw at least one other report of this, but I can't find it.
Flags: needinfo?(mkmelin+mozilla)
Whiteboard: [regression:TB30][DUPEME] → [regression:TB30]
Thomas can you attach a stacktrace file to the bug report?
see https://wiki.mozilla.org/Thunderbird:Testing:Shutdown_Hang
Flags: needinfo?(thomas.raddatz)
(Reporter)

Comment 21

3 years ago
Of course I can do that, but unfortunately not for the next 14 days.
(Reporter)

Comment 22

3 years ago
Created attachment 8491513 [details]
Thunderbird 34.0.0.5345 stacktrace Win7 64-Bit

Please find the stacktrace attached as "thunderbird-debug_1b00_2014-09-18_16-04-37-947.log". I hope that I did it right and that it helps to find the problem. It might be worth to mention that I moved from Win7 32-bit to Win7 64-bit meanwhile. I did not install the 64-bit version on top of the 32-bit Win7 but did a fresh install from scratch.
Flags: needinfo?(thomas.raddatz)
Whiteboard: [regression:TB30] → [regression:TB30][has stacktrace]
Does it reproduce with version 38 beta?
http://www.mozilla.org/en-US/thunderbird/all-beta.html
Flags: needinfo?(thomas.raddatz)
(Reporter)

Comment 24

2 years ago
I installed 38.0b4 into a virtual machine (VirtualBox, Win7 64Bit) and I could not reproduce the error.

But I also cannot reproduce it with 31.6.0, which is the current release that I use on my desktop PC (Win7, 64Bit). I do not know when the problem vanished. Actually I intended to stay with 24.7.0 as long as possible. But obviously I updated it somewhen in the past.
Flags: needinfo?(thomas.raddatz)
Thanks for the update.  So whatever made this go away for you would have been in 31.5.0 or 31.6.0
Blocks: 1149287
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Summary: thunderbird.exe process still around after all windows closed → thunderbird.exe process still around after all windows closed (shutdown hang)
You need to log in before you can comment on or make changes to this bug.