If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't start the versioncheck and theme_update services

RESOLVED FIXED in 2014-09

Status

addons.mozilla.org Graveyard
Compatibility Tools
P1
major
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: magopian, Assigned: magopian)

Tracking

unspecified
2014-09
x86_64
Linux

Details

(Whiteboard: [qa-])

(Assignee)

Description

3 years ago
Trying to start the wsgi services versioncheck and theme_update fail with the given stacktraces:
- https://jason.pastebin.mozilla.org/6054035
- https://jason.pastebin.mozilla.org/6054036

This seems to be caused by the following commit: https://github.com/mozilla/olympia/commit/986d8670de51cfd009bafec2b4aaa65335397860

To reproduce, simply run:
$ python services/wsgi/versioncheck.py
PR: https://github.com/mozilla/olympia/pull/219
Assignee: nobody → mathieu

Updated

3 years ago
Blocks: 1054907
(Assignee)

Comment 2

3 years ago
Fixed in https://github.com/mozilla/olympia/commit/a4203731f4a0f2501642802170ffb6749067dd8a
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

3 years ago
This issue also exists in services/theme_update.py
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

3 years ago
new PR: https://github.com/mozilla/olympia/pull/220
(Assignee)

Comment 5

3 years ago
Fixed (again) in https://github.com/mozilla/olympia/commit/9e035aeaff54e78d0ad1156c4ec42421ee853dd9
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 6

3 years ago
Please add STR here or mark it with [qa-] if no QA is needed.
Flags: needinfo?(mathieu)
(Assignee)

Comment 7

3 years ago
Marked as qa- ;)
Flags: needinfo?(mathieu)
Whiteboard: [qa-]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.