Scrolling on Bing locked when toolbar reappears over search field

VERIFIED FIXED in Firefox 34

Status

()

defect
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: wesj)

Tracking

({reproducible})

unspecified
Firefox 36
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox32 wontfix, firefox33 wontfix, firefox34 verified, firefox35 verified, firefox36 verified, fennec34+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

Currently, when one scrolls downwards on Bing, the dynamic toolbar fades away. At the end of the scroll the dynamic toolbar will re-appear over their search field. At that point scrolling becomes locked and it is not possible to scroll back up to the top of the page.

This may be dependent on screen-size. I am able to reproduce this on my Nexus 5 (Android 4.4.4) but not tested any other devices or channels right now.

Visit http://bing.com, scroll to the bottom, try scrolling back up.

Is this related to the recent change that made the dynamic toolbar re-appear at the bottom of content?

--
Nightly (08/19)
LG Nexus 5 (Android 4.4.4)
On my nexus 4 i see this on nightly but not aurora or release. On beta the page is not scrollable. Even on nightly it is possible to recover it looks like; sometimes if i scroll back on the right edge of the page i can scroll the toolbar off.
(Assignee)

Updated

5 years ago
Blocks: 973727
(Assignee)

Comment 2

5 years ago
I think maybe we should make the toolbar showing dependent on the page length being over some minimum (twice the screen height? screenheight + toolbarheight?)
We talked about backing bug 973727 out of Aurora to fix this for 34.
Assignee: nobody → wjohnston
tracking-fennec: ? → 34+
Wes - Ping
Flags: needinfo?(liuche)
Flags: needinfo?(liuche) → needinfo?(wjohnston)
(Assignee)

Comment 5

5 years ago
Posted patch PatchSplinter Review
This doesn't show the urlbar if the page is shorter than twice the viewport height. I worry that will seem confusing to users. OTOH, maybe it feels magic.
Attachment #8505031 - Flags: review?(bugmail.mozilla)
Flags: needinfo?(wjohnston)
Comment on attachment 8505031 [details] [diff] [review]
Patch

Review of attachment 8505031 [details] [diff] [review]:
-----------------------------------------------------------------

It probably will feel a bit like magic but overall it's probably a good solution, at least until we find something better.

::: mobile/android/base/BrowserApp.java
@@ +1305,3 @@
>          if (metrics.getPageHeight() < metrics.getHeight()
>                || metrics.marginTop >= mToolbarHeight / 2
> +              || (metrics.pageRectBottom == metrics.viewportRectBottom && metrics.pageRectBottom > 2*height)) {

nit: spaces around '*'
Attachment #8505031 - Flags: review?(bugmail.mozilla) → review+
(Assignee)

Comment 8

5 years ago
Comment on attachment 8505031 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 973727
[User impact if declined]: Urlbar can obscure content forever
[Describe test coverage new/current, TBPL]: I don't think we have tests for the dynamic toolbar yet
[Risks and why]: fairly low risk. Just adding an additional condition check to prevent this from showing if the page is fairly short (less than twice the screen height)
[String/UUID change made/needed]: none
Attachment #8505031 - Flags: approval-mozilla-beta?
Attachment #8505031 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ccadeded76c4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
The status flags here are still ? - can we get confirmation of the regression range here and how high this needs to uplift?
Flags: needinfo?(aaron.train)
Regression range:
good build: 14-08-2014
bad build: 15-08-2014
pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5299864050ee&tochange=c9f8cc9ce89c

I am not able to reproduce the issue on latest 36.0a1 Nightly (2014-10-22)
I am still able to reproduce on 35.0a2 Aurora(2014-10-22) and 34 Beta 2.
Comment on attachment 8505031 [details] [diff] [review]
Patch

Beta+
Aurora+
Attachment #8505031 - Flags: approval-mozilla-beta?
Attachment #8505031 - Flags: approval-mozilla-beta+
Attachment #8505031 - Flags: approval-mozilla-aurora?
Attachment #8505031 - Flags: approval-mozilla-aurora+
(Reporter)

Updated

5 years ago
Flags: needinfo?(aaron.train)
Verified fixed on:
Device: Nexus 5
OS: Android 4.4
Builds: Firefox for Android 36.0a1 (2014-10-26) and Firefox for Android 35.0a2 (2014-10-26)

Comment 15

5 years ago
Verified as fixed on Firefox 34 Beta 6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.