Update Gip job to use tests/manifest.ini and --type=b2g-external

RESOLVED DUPLICATE of bug 1084288

Status

defect
RESOLVED DUPLICATE of bug 1084288
5 years ago
a year ago

People

(Reporter: zcampbell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2313] )

(Reporter)

Description

5 years ago
Currently Gip job has its own manifest file but this makes the test sets a bit inconsistent.

In bug 1044484 we've added an `external` tag so that we can exclude tests that use external/internet resources. 

If we run Gip with --type=b2g-external then we get the same set of tests as the old tbpl-manifest.ini and all in a shared manifest file and hence easier maintenance.
(Reporter)

Updated

5 years ago
Blocks: 1056008
No longer blocks: 1046694
Depends on: 1046694
(Reporter)

Updated

5 years ago
Depends on: 1084288

Updated

5 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2310]

Updated

5 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2310] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2313]
(Reporter)

Comment 1

5 years ago
Bug 1084288 will resolve this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1084288
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.