Update Firefox_for_developers macro to list newer versions too

RESOLVED DUPLICATE of bug 855636

Status

Developer Documentation
General
P5
normal
RESOLVED DUPLICATE of bug 855636
4 years ago
4 months ago

People

(Reporter: sheppy, Assigned: sheppy)

Tracking

Details

(URL)

(Assignee)

Description

4 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

It's been suggested -- rightly, I think, that it would be useful if the links to other release notes at the end of each Firefox X for developers page included both older *and* newer versions. The way we do things now was decided on intentionally, but I'm no longer convinced that it was the right call.

So let's make this macro automatically insert a "Newer versions" heading with a list of those versions, then an "Older versions" list with those versions' links.

That'd mean going through existing Firefox X for developers pages and removing the manually-inserted "Older versions" headers we have, but I think it would be worthwhile for usability and flexibility.
I was wondering yesterday if we shouldn't make something like:

Developer notes for newer Firefox
21 22 23 24 25 26 27 28 29 30 31 32 33 34

Developer notes for older Firefox
20 19 18 17 16 15 14 13 12 11 10 9 8 7 6 5 4 3.6 3.5 3.0 2.0 1.5

Removing the "older versions" header is still needed (but we need to refresh the 36 pages anyway), but it starts to be a very long section with "Firefox 12 for developers".
And we should make these pages auto-regenerate every 6 weeks.
(Assignee)

Comment 3

4 years ago
(In reply to Jean-Yves Perrier [:teoli] from comment #1)
> I was wondering yesterday if we shouldn't make something like:
> 
> Developer notes for newer Firefox
> 21 22 23 24 25 26 27 28 29 30 31 32 33 34
> 
> Developer notes for older Firefox
> 20 19 18 17 16 15 14 13 12 11 10 9 8 7 6 5 4 3.6 3.5 3.0 2.0 1.5

Agreed. This is a good idea (although we might want to do something like make each version number appear in a little "bubble" to help keep it from just looking like a jumble of numbers.

> Removing the "older versions" header is still needed (but we need to refresh
> the 36 pages anyway), but it starts to be a very long section with "Firefox
> 12 for developers".

Yep.

> And we should make these pages auto-regenerate every 6 weeks.

Yes, absolutely.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855636
You need to log in before you can comment on or make changes to this bug.