Closed Bug 1056043 Opened 6 years ago Closed 5 years ago

Move chromecast server to point to a mozilla.org hosted site, not to people.m.o

Categories

(Firefox for Android :: Screencasting, defect)

34 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fennec 34+ ---

People

(Reporter: krudnitski, Assigned: nalexander, NeedInfo)

References

Details

This needs to happen prior to Fx 33 beta (Sept 2) if this feature will, indeed, hit Fx 33 beta. Not sure who this should be assigned to.
So we need a few things:
1. Create a real Mozilla account. Can Brad tell Coop where this is done? Then Coop can pass us the email under PGP email.
2. We need to review thew code. Brad has a separate bug for that.
3. We need to update the "key" in Fennec when the new account is registered.
4. Is there a four?
tracking-fennec: ? → 34+
Flags: needinfo?(coop)
Flags: needinfo?(blassey.bugs)
(In reply to Mark Finkle (:mfinkle) from comment #1)
> So we need a few things:
> 1. Create a real Mozilla account. Can Brad tell Coop where this is done?
> Then Coop can pass us the email under PGP email.
> 2. We need to review thew code. Brad has a separate bug for that.
> 3. We need to update the "key" in Fennec when the new account is registered.
> 4. Is there a four?

#4 is getting a non-people.m.o place to host this. NI to Laura to tell us how to do that.
Flags: needinfo?(blassey.bugs) → needinfo?(laura)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #2)
> (In reply to Mark Finkle (:mfinkle) from comment #1)
> > So we need a few things:
> > 1. Create a real Mozilla account. Can Brad tell Coop where this is done?
> > Then Coop can pass us the email under PGP email.
> > 2. We need to review thew code. Brad has a separate bug for that.
> > 3. We need to update the "key" in Fennec when the new account is registered.
> > 4. Is there a four?
> 
> #4 is getting a non-people.m.o place to host this. NI to Laura to tell us
> how to do that.

LOL - right

I was thinking of using our CDN system like we do for OTA distributions. Richard has experience with posting to that system. I think we "only" need a directory where we can put the files. Maybe with a way to create a "v1" style versioning?
Flags: needinfo?(rnewman)
Pretty straightforward. Clone Bug 1020033!
Flags: needinfo?(rnewman)
(In reply to Mark Finkle (:mfinkle) from comment #1)
> So we need a few things:
> 1. Create a real Mozilla account. Can Brad tell Coop where this is done?
> Then Coop can pass us the email under PGP email.

Is this the Tools->Set Up Sync... menu option? 

If so, any stipulation on the email used? Specifically, is this account something that releng would manage or something that the mobile team would manage?

Also, do I need to "Choose what to sync" as part of the process, or is the default fine?
Flags: needinfo?(coop) → needinfo?(blassey.bugs)
(In reply to Chris Cooper [:coop] from comment #5)

> > 1. Create a real Mozilla account. Can Brad tell Coop where this is done?
> > Then Coop can pass us the email under PGP email.
> 
> Is this the Tools->Set Up Sync... menu option? 

I think Mark means "Create a real Google Chromecast application account for Mozilla, rather than using Brad or Mark's personal dev account".
(In reply to Chris Cooper [:coop] from comment #5)
> (In reply to Mark Finkle (:mfinkle) from comment #1)
> > So we need a few things:
> > 1. Create a real Mozilla account. Can Brad tell Coop where this is done?
> > Then Coop can pass us the email under PGP email.


https://developers.google.com/cast/docs/registration
https://cast.google.com/publish
Flags: needinfo?(blassey.bugs) → needinfo?(coop)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #7)
> (In reply to Chris Cooper [:coop] from comment #5)
> > (In reply to Mark Finkle (:mfinkle) from comment #1)
> > > So we need a few things:
> > > 1. Create a real Mozilla account. Can Brad tell Coop where this is done?
> > > Then Coop can pass us the email under PGP email.
> 
> https://developers.google.com/cast/docs/registration
> https://cast.google.com/publish

Are there any stipulations about *where* the account should be setup, or more specifically, paid from? I think US citizens have always setup these accounts in the past, but I'm not sure whether that is required or not.

I'm happy to pay for the account from Canada, but don't want to lock the account out of, e.g., US distribution by doing so, since the associated Wallet would have my Canadian details in it.
Flags: needinfo?(coop)
(In reply to Mark Finkle (:mfinkle) from comment #1)
> Then Coop can pass us the email under PGP email.

The account has been created. No point in standing on ceremony for comment #8.

Who needs access? Point me at your public key and I'll send you the encrypted details.
(In reply to Chris Cooper [:coop] from comment #9)
> (In reply to Mark Finkle (:mfinkle) from comment #1)
> > Then Coop can pass us the email under PGP email.
> 
> The account has been created. No point in standing on ceremony for comment
> #8.
> 
> Who needs access? Point me at your public key and I'll send you the
> encrypted details.

Sending you my key so we have at east one other person on the team with creds.
mfinkle has the account details now.
Assignee: nobody → nalexander
Nick: the assignee thing here is "work with cturra and blassey to get this on a CDN, just like Bug 1020033".

We picked you because of your coincidental seat location.
Status: NEW → ASSIGNED
Depends on: 1080190
cturra and I talked, and I took two action items:

1) setting a timeline.  cturra suggests that he can turn this around (the s3 and cdn registration) in the next two weeks, with a hard deadline of Fennec 34 going to GA.  (Fennec 34 merges to Beta in 5 days and heads to release in about 6 weeks (mid-November).)  mfinkle, blassey: speak up if that timeline is not acceptable.

2) inquiring about how general this should be.  cturra told me that they generally set up CDN fronting that looks like https://PREFIX.cdn.mozilla.net, but he asked about making a more general thing that might look like https://app.cdn.mozilla.net/chromecast, so that when we want to host /roku or /other_binary we're ready to do it.  mfinkle, blassey: it seems like a little generality might be useful in future, but I don't actually know of any other binaries we might want to push out there in the near future.  Do you have perspectives?
Flags: needinfo?(mark.finkle)
Flags: needinfo?(blassey.bugs)
My 2¢: I am totally fine (ab)using the distro CDN for this if it gets us there faster.

No, it's not ideal naming, but you could squint and say we're distributing bits for Fennec, or distributing Chromecast apps, or whatever.

That has the handy property of being ready to go *today*.
FWIW... this is just a static web page. Sticking it somewhere on mozilla.org or mozilla.com should be fine. Also, the user will *never* see the url.
Flags: needinfo?(blassey.bugs)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #15)
> FWIW... this is just a static web page. Sticking it somewhere on mozilla.org
> or mozilla.com should be fine. Also, the user will *never* see the url.

I think the CDN gives us better delivery, and allows us to easily upload new versions. Agreed on the user never seeing the URL. I am OK with https://app.cdn.mozilla.net/chromecast
Flags: needinfo?(mark.finkle)
The current chromecast server code repository lives here:

https://github.com/mozilla/chromecast-server

It is currently being reviewed in Bug 1048335.
:mfinkle - random thought. looking at the s3 bucket/cdn setup i did for distro-download.cdn.mozilla.net, it doesn't look very used. i wonder if it would be appropriate to put the chromecast binaries here as well. something like...

 distro-download.cdn.mozilla.net/chomecast/

or..

 distro-download.cdn.mozilla.net/android/chromecast/


what i am hoping to achieve here is a more generic setup rather than one-off setups for each request. thoughts on this approach?
Flags: needinfo?(mark.finkle)
I am OK with doing a generic setup, but "distro-download' is not very generic. Given that downloadable distros are maybe in Fx34, likely in Fx35, I'd be fine with killing "distro-download" and creating something more generic. I don't have a great idea for what that is though.

"chromecast" would be mostly used for mobile, Android and iOS, type stuff. "distributions" would be used for mobile, Android for now. So maybe "mobile.cdn.mozilla.net" ? Too generic?

mobile.cdn.mozilla.net/distributions
mobile.cdn.mozilla.net/chromecast

Thoughts Chris, Nick, Brad, and Richard?
Flags: needinfo?(rnewman)
Flags: needinfo?(nalexander)
Flags: needinfo?(mark.finkle)
Flags: needinfo?(cturra)
Flags: needinfo?(blassey.bugs)
I really don't care about the url since the user will never see it
Flags: needinfo?(blassey.bugs)
Fine by me. It'd be an easy patch to uplift. But I also don't think we'd ever expose the CDN URL to users, so I wouldn't mind at all if we just used the 'wrong' name.
Flags: needinfo?(rnewman)
i really believe we're best served keeping this generic. if the current distro-download.cdn.mozilla.net name needs to be changed, just let me know.
Flags: needinfo?(cturra)
This will naw at me, so let's change the name to: mobile.cdn.mozilla.net

Chris: I think Richard has access to push files. Can others be added too?

Richard: We can get a patch to change this in Fennec once Chris let's us know it's been changed.
NI to cturra to make sure he's not blocked on mobile team.
Flags: needinfo?(nalexander) → needinfo?(cturra)
UPDATE: We might have a partnership going live soon that would need downloadable distributions. This means we'll need to transition the CDN changes, not do a straight rename.

Chris - Can you make a new bucket for us using the name: mobile.cdn.mozilla.net, but keep the old one for now. We can drop the old one soon enough, but I don't want to get backed into a tight spot if we can't updated the URL in the client ASAP.
:( i started doing all the refactor work yesterday, which included some removal of the distro-download setup. if this is required again, i will need to redo that work.

lets continue this discussion in bug 1080190, which covers the s3/cdn work i am doing. and pls, keep me in the loop with any other work that might be dependent on this.
Flags: needinfo?(cturra)
Duplicate of this bug: 1087993
Looks like this is all good.  Thanks, folks!
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.