Closed Bug 1056303 Opened 5 years ago Closed 5 years ago

[e10s] many pages are not rendered until I switch tabs

Categories

(Core :: Graphics, defect, P1)

x86
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1049551

People

(Reporter: cpeterson, Assigned: handyman)

Details

(Keywords: regression)

This problem seemed to have started within the past week. I see it on two different Retina MBPs.

I don't have 100% STR, but when I load a page, usually in a new tab, the page seems to load but nothing is rendered. If I switch to a different tab and then back, the page will render as expected.
In a clean profile, flipping layers.acceleration.disabled to true also causes pages to not be rendered on OS X. However, switching between tabs does not force them to render. 

Loading Flash content with e10s and layers.acceleration.disable = true crashes with bug 1056311.
Assignee: nobody → davidp99
Blocks: old-e10s-m2
I still see these blank tabs all the time on two different MacBook Pros. The problem seems to happen most when first switching to a tab I opened in the background or when I close a tab and the adjacent tab receives focus. Similarly, I sometimes switch to a tab which doesn't repaint for 2–3 seconds.

I couldn't reproduce the problem in a debug build after an hour of use, whereas I see the problem every couple minutes or more in a release build with the same profile.
(In reply to Chris Peterson (:cpeterson) from comment #2)
> I still see these blank tabs all the time on two different MacBook Pros. The
> problem seems to happen most when first switching to a tab I opened in the
> background or when I close a tab and the adjacent tab receives focus.
> Similarly, I sometimes switch to a tab which doesn't repaint for 2–3 seconds.

I have been seeing this too, under circumstances very similar to the above.
See Also: → 1058735
I tried to bisect this intermittent bug. I was able to reproduce it as early as Nightly 34 build 2014-08-06, though the bug happens much more frequently in recent builds.
Duplicate of this bug: 1059421
I'm pretty certain this was caused by the work that handyman and I did in bug 1009628 - and it's probably in the front-end stuff I did.
Blocks: 1009628
OS: Mac OS X → All
Bug 1009628 definitely sounds like the culprit. I reproduced this bug in build 2014-08-06, but I haven't been able to reproduce it 2014-08-01 and 2014-08-03. (I haven't tested 2014-08-04 or 2014-08-05.)
Hey Mike,

I've got what I'm hoping is a related bug in Bug 1059036.  I'm hoping because its a 100% repro (for me) and because I've narrowed down the issue to the point that I could fix it with a small patch (already posted to that bug).  You know this code much better than I do and I think my patch isn't quite kosher but I'm hoping it can help get us primed.  Can you take a look at it and give me your thoughts?
Flags: needinfo?(mconley)
Sure - I've feedbacked myself on the patch, and looking at it now.
Flags: needinfo?(mconley)
Local testing suggests that this is fixed by bug 1059036. Going to leave this open until that patch gets into a Nightly and we can kick the tires, but I'm encouraged.
I haven't seen this on the latest nightly yet...
Ditto, and I've been testing pretty aggressively. Let's say this was fixed by bug 1059036. Please re-open if this rears its head again.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Bug is resolved - clearing outdated QA-Wanted tags
You need to log in before you can comment on or make changes to this bug.