Closed Bug 993639 (e10s-gfx) Opened 6 years ago Closed 11 days ago

[meta] e10s Graphics Issues

Categories

(Core :: Graphics, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
e10s + ---

People

(Reporter: billm, Assigned: bas.schouten)

References

(Depends on 5 open bugs)

Details

(Keywords: meta)

Matt asks for a bug that specifically tracks graphics issues related to e10s.
Adding Cwiis, Bas and nical to the cc list since they are now actively working on OMTC.

Some of these bugs may be specific to e10s, but I suspect the majority of them will affect all OMTC. The e10s guys are probably the biggest users of OMTC right, so this is a good place to look :)

Chris, bug 972728 in particular will need to be fixed before BasicCompositor performs well enough, see http://mxr.mozilla.org/mozilla-central/source/gfx/layers/basic/BasicCompositor.cpp#404
Flags: needinfo?(chrislord.net)
Actually that bug number is fixed, the code in question was landed as part of bug 980122. And refers to an unfiled issue about tab switching not repainting (almost certainly e10s specific).

I have a theory about that bug, and have asked billm to test it. Hopefully we can fix that and remove the code stopping us from doing minimal composites.
(In reply to Matt Woodrow (:mattwoodrow) from comment #2)
> Actually that bug number is fixed, the code in question was landed as part
> of bug 980122. And refers to an unfiled issue about tab switching not
> repainting (almost certainly e10s specific).
> 
> I have a theory about that bug, and have asked billm to test it. Hopefully
> we can fix that and remove the code stopping us from doing minimal
> composites.

huh, so disabling this (I'm not testing with e10s, ftr), I see lots of other interesting rendering glitches where masked layer contents appears vertically offset - I've seen similar errors in release, so I'm not hugely concerned, but we should probably fix them :p
Flags: needinfo?(chrislord.net)
Depends on: 994546
Depends on: 994969
Depends on: 1009148
Depends on: 1009628
tracking-e10s: --- → +
Keywords: meta
OS: Linux → All
Hardware: x86_64 → All
Depends on: 1028859
Depends on: 1100510
Duplicate of this bug: 1111396
Alias: gfx-e10s → e10s-gfx
Assignee: nobody → bas
See Also: 1111396
Summary: [e10s] Graphics metabug → [meta] e10s Graphics Issues
Duplicate of this bug: 1116575
Ok, this is *the* e10s gfx tracker.
Flags: needinfo?(milan)
Flags: needinfo?(milan)
Depends on: 1210050
Depends on: 1204223
No longer depends on: 1100252
Depends on: 1232549
Depends on: 1247025
Depends on: 1253241
Depends on: 1253386
Depends on: 1257061
Depends on: 1252677
Depends on: 1268559
Depends on: 1270130
Blocks: 1363015
No longer blocks: 1363015
Depends on: 1363015
No longer depends on: 1363015
Depends on: 1363015
No longer depends on: 1363015
Status: NEW → RESOLVED
Closed: 11 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.