Closed Bug 1057081 Opened 10 years ago Closed 10 years ago

[SMS] The text cursor is being cut off when editing an SMS message

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected)

RESOLVED DUPLICATE of bug 1021499
Tracking Status
b2g-v2.1 --- affected

People

(Reporter: jschmitt, Unassigned)

References

Details

(Whiteboard: [2.1-flame-test-run-1])

Attachments

(1 file)

Attached image Cursor.png
Description:
The text cursor is being cut off by the keyboard.

Repro Steps:
1) Update a Flame to 20140821040201
2) Open  the SMS app
3) Create a new message
4) Select the 'Body' text field

Actual:
The cursor is cut off.

Expected:
The cursor is not cut off.

Environmental Variables:
Device: Flame Master
Build ID: 20140821040201
Gaia: 3584b2723412ed3299c6761f465885d80651c87e
Gecko: dac8b4a0bd7c
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes:
Repro frequency: 100%
See attached: screenshot
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
New feature for 2.1 and not a regression, need info on the QA lead for blocking nomination triage.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(edchen)
This looks like more common Core Selection issue described in bug 1021499.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(In reply to Oleg Zasypkin [:azasypkin] from comment #2)
> This looks like more common Core Selection issue described in bug 1021499.

Yeah, should be the same one. Ni? gecko devs for more information.
Flags: needinfo?(mtseng)
See Also: → 1021499
Yap, they are the same. Unfortunately, the implementation is putting cursor's frame inside the app now. So we cannot overlapped cursor to other app like keyboard app. We'll find better solution for this.
Flags: needinfo?(mtseng)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Flags: needinfo?(edchen)
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
Whiteboard: [2.1-flame-test-run-1]
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)
Ok, as we agreed with Steve today and per comment 4, we're closing this bug as duplicate of Core Selection bug 1021499.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.