Transparent animated GIF displays incorrectly

RESOLVED FIXED in Future

Status

()

--
major
RESOLVED FIXED
17 years ago
5 years ago

People

(Reporter: it, Assigned: nivedita)

Tracking

({platform-parity})

Trunk
Future
x86
All
platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs superreview], URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

An animated GIF which is supposed to display in red (and does so in Netscape
4.77) is completely transparently where the red is supposed to be.

Reproducible: Always
Steps to Reproduce:
1. Point Browser to http://www.michael-noakes.co.uk/
2. Watch image below "View here"


Actual Results:  Animation starts, but where it should be red, it is transparent

Expected Results:  Animation should've been in red.
imagelib.  For reference, with trunk build 2001-10-18-08 on linux I cannot see
the animated gif at all!
Assignee: pchen → pavlov
Status: UNCONFIRMED → NEW
Component: XP Apps → ImageLib
Ever confirmed: true
OS: Windows 98 → All
QA Contact: sairuh → tpreston

Comment 2

17 years ago
worksforme (: 2001101808 redhat 7.0+

Comment 3

17 years ago
I still see this behavior on Win XP build 2001110209

Comment 4

17 years ago
Is there any news about this ? It is one of the bug that makes advocacy of
Mozilla harder.

Comment 5

17 years ago
Still there, win98SE, 2002010403.  The .gif looks fine in Irfanview and IE5.5

Updated

17 years ago
Blocks: 119597

Comment 6

17 years ago
WFM linux, cvs tip...
setting pp keyword
Keywords: pp

Updated

17 years ago
Target Milestone: --- → Future

Comment 7

17 years ago
Created attachment 68348 [details]
testcase (image in question with different background colors)

build 2002020603 win32 trunk

still seeing the bug. Could this be a dup?
(Assignee)

Comment 8

17 years ago
taking this bug from pavlov
Assignee: pavlov → nivedita
(Assignee)

Comment 9

17 years ago
Created attachment 70257 [details] [diff] [review]
patch file for fixing the transparent animated gif

The disposal method of animated the gif was DISPOSE_NOT_SPECIFIED, and here the
BuildCompositeMask was not being called which correctly handles the masking of
overlay frame and its background. Since DISPOSE_KEEP was already doing this.
Hence clubbed the cases of DISPOSE_NOT_SPECIFIED and DISPOSE_KEEP
(Assignee)

Updated

17 years ago
Keywords: patch
Whiteboard: needs r=
(Assignee)

Updated

17 years ago
Whiteboard: needs r= → [needs r=]

Comment 10

17 years ago
is the patch ready for review?
Keywords: mozilla1.0
(Assignee)

Comment 11

17 years ago
yes, it is ready for review.
(Assignee)

Updated

17 years ago
Whiteboard: [needs r=] → [needs review/superreview]

Comment 12

17 years ago
Comment on attachment 70257 [details] [diff] [review]
patch file for fixing the transparent animated gif

r=pavlov
Attachment #70257 - Flags: review+
(Assignee)

Updated

17 years ago
Whiteboard: [needs review/superreview] → [needs superreview]

Comment 13

17 years ago
WFM without the patch - red signature, transparent background.
(Assignee)

Comment 14

17 years ago
Can you please verify the given test case, where in differnt back ground colors 
are used. On the white back ground, the red signature is clear, but when against 
the other background color, the signature appears in red+background color. That 
is reason why BuildCompositeMask is needed.
(Assignee)

Comment 15

17 years ago
The test case id=68348 happens on Windows platform.

Comment 16

17 years ago
Without patch transparency appears correct on all backgrounds in the testcase.
(Assignee)

Comment 17

17 years ago
This test case is valid for Windows platform.
tor, it doesn't work in windows.. just open IE and take a look at the
difference, there is no animation and the background color of the signature is
not the correct color even on the URL testcase, and the attached testcase.

Nivedita, 

this is definitely not fixed without the patch on windows 2000; build 2002-03-01-03.

Comment 19

17 years ago
Comment on attachment 70257 [details] [diff] [review]
patch file for fixing the transparent animated gif

sr=tor
Attachment #70257 - Flags: superreview+
Comment on attachment 70257 [details] [diff] [review]
patch file for fixing the transparent animated gif

a=asa (on behalf of drivers) for checkin to the 0.9.9 branch and the 1.0 trunk
Attachment #70257 - Flags: approval+

Comment 21

17 years ago
Fixed with chekin

on trunk
C:\mozilla\modules\libpr0n\src>cvs commit
cvs commit: Examining .
Checking in imgContainer.cpp;
/cvsroot/mozilla/modules/libpr0n/src/imgContainer.cpp,v  <--  imgContainer.cpp
new revision: 1.27; previous revision: 1.26
done

On 099 branch
C:\moz099\mozilla\modules\libpr0n\src>cvs commit
cvs commit: Examining .
Checking in imgContainer.cpp;
/cvsroot/mozilla/modules/libpr0n/src/imgContainer.cpp,v  <--  imgContainer.cpp
new revision: 1.26.2.1; previous revision: 1.26
done
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.