If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Perma-failures on b-i, ime_uninstallation_test.js, uninstallation_test.js

RESOLVED FIXED in 2.1 S3 (29aug)

Status

Firefox OS
Gaia
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kgrandon, Assigned: tedders1)

Tracking

unspecified
2.1 S3 (29aug)
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Suspecting this is caused by bug 1042797. https://tbpl.mozilla.org/php/getParsedLog.php?id=46702680&tree=B2g-Inbound
(Reporter)

Comment 1

3 years ago
Ted - can you try running these tests locally to verify that we can still uninstall keyboards?

The failing tests are: apps/keyboard/test/marionette/uninstallation_test.js
apps/settings/test/marionette/tests/ime_uninstallation_test.js
Flags: needinfo?(tclancy)
(Reporter)

Comment 2

3 years ago
And it appears the whole world started failing like crazy on the latest b2g-inbound: https://tbpl.mozilla.org/php/getParsedLog.php?id=46741568&tree=B2g-Inbound
Created attachment 8478793 [details] [review]
Patch V1

It seems some test fixing patches were not landed correctly, see bug 1000315 comment 65.

This is a patch to fix those tests, and could run locally.
Let's see how it runs on Gaia-Try.
Attachment #8478793 - Flags: review?(kgrandon)
(Reporter)

Comment 4

3 years ago
Comment on attachment 8478793 [details] [review]
Patch V1

Argh, R+ assuming we get a green try run. Thanks so much for tracking this down.
Attachment #8478793 - Flags: review?(kgrandon) → review+
(Reporter)

Comment 5

3 years ago
Just an update that Ted thinks this patch won't fix it due to some changes last week. If we don't get a green try run from it, and Ted can't fix it, then we will backout the regressing patches.
(Reporter)

Comment 6

3 years ago
If we backout, we would backout all of these patches: https://tbpl.mozilla.org/?tree=B2g-Inbound&showall=1&rev=4b37cddaed77

As well as gaia changes here: https://hg.mozilla.org/integration/b2g-inbound/rev/a840609deb46
(Reporter)

Updated

3 years ago
Blocks: 1055427
(Reporter)

Updated

3 years ago
Blocks: 1000315
(Assignee)

Comment 7

3 years ago
Created attachment 8478857 [details] [review]
Bug 1058362 - Fix failing gaia integration tests. r=timdream
Assignee: nobody → tclancy
Attachment #8478793 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8478857 - Flags: review?(timdream)
Flags: needinfo?(tclancy)
Attachment #8478857 - Flags: review?(timdream) → review+
(In reply to Kevin Grandon :kgrandon from comment #5)
> Just an update that Ted thinks this patch won't fix it due to some changes
> last week. If we don't get a green try run from it, and Ted can't fix it,
> then we will backout the regressing patches.

It turned out Rudy's patch turned green (not really green, just failed on some other stuff and not the one to be fixed.) but after discussion with Rudy he agreed we should land Ted's fix as apparently it's formatted in a better way.

So, this is the Try run we are now waiting on:

https://tbpl.mozilla.org/?rev=27ba765e270d58138fbb5f2134944566a24b0925&tree=Gaia-Try
master: https://github.com/mozilla-b2g/gaia/commit/c710c7fac2987bc0f3ea76a2361fe16e995468a0
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe]
Target Milestone: --- → 2.1 S3 (29aug)
You need to log in before you can comment on or make changes to this bug.