Closed Bug 1058442 Opened 5 years ago Closed 5 years ago

sanitize.js should pass the date range being cleared to the permission manager and content pref service

Categories

(Firefox :: General, defect)

defect
Not set
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 36
Iteration:
35.3
Tracking Status
firefox36 --- verified

People

(Reporter: markh, Assigned: markh)

References

Details

Attachments

(1 file)

In order to complete bug 771630, sanitize.js needs to take advantage of the new features added by the dependent bugs and pass the relevant date range to them.

This should be relatively simple - most of the heavy-lifting is done in those other bugs.
Flags: qe-verify-
Flags: firefox-backlog+
Blocks: 1050080
Removing the password manager from this bug - bug 1058438 is calling for login manager stuff to end up in the permission manager anyway, so the correct sanitize behaviour for it will happen "for free" at that point.
No longer depends on: 1058438
Summary: sanitize.js should pass the date range being cleared to the permission manager, content pref service and password manager → sanitize.js should pass the date range being cleared to the permission manager and content pref service
This patch seems to work fine, but I'm having trouble adding tests to the existing sanitize tests, as none of these interfaces support "faking" the creation date - this is the same problem cookies have and why that also isn't tested by browser_sanitize-timespans.js.  However, given the interfaces in question do all have tests for their remove*Since() methods, I think we can probably get away with just manual QA here - Matt, what do you think?
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Attachment #8503876 - Flags: feedback?(MattN+bmo)
Iteration: --- → 35.3
Comment on attachment 8503876 [details] [diff] [review]
0001-Bug-1058442-sanitize.js-now-passes-the-date-range-be.patch

Review of attachment 8503876 [details] [diff] [review]:
-----------------------------------------------------------------

A manual verification is fine.
Attachment #8503876 - Flags: feedback?(MattN+bmo) → review+
Thanks!

https://hg.mozilla.org/integration/fx-team/rev/e997cbe0c5b6
Flags: qe-verify- → qe-verify+
https://hg.mozilla.org/mozilla-central/rev/e997cbe0c5b6
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
This looks like a dependency for fixing other bugs, so it seems to me like verification for this would be included in verification of the blocked issues. 

Please either set as qe-verify- if the above is true, or provide the QA team with testing details if this needs to be verified separately.
Please verify that when you clear recent history, site permissions (eg, allow images/location/etc) and site-specific preferences (eg, zoom level) are cleared or retained correctly with respect to the time-range specified.  Previously, all such permissions/preferences were cleared regardless of the specified time-range.

See bug 771630 for more - while this bug doesn't fully fix that one, it does fix the most visible/important (ie, perms and prefs).  Please explicitly also check bug 1005333 is fixed by this (which is almost certainly just one such permission)
Verified fixed on Windows 7 64bit, Ubuntu 13.10 and Mac OSX 10.9.5 using Firefox 36 Beta 1 (build2), buildID: 20150114125146.
Status: RESOLVED → VERIFIED
Regressions: 1557153
You need to log in before you can comment on or make changes to this bug.