Firefox 31 x64 on Linux [Mageia 4 x64] not working h.264 in YouTube

RESOLVED WORKSFORME

Status

()

P5
normal
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: xpris, Unassigned)

Tracking

31 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8479093 [details]
look at lack h.264 support or bugs

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

1) Install Firefox 31 x64, on Linux system 64 bit for me was the Mageia 4, x64, KDE.
2) Go to YouTube / HTML5 test page. See if H.264 codec is supported.
3) Confront support h.264 or lack thereof with the site html5test.com


Actual results:

I do not have support H.264 in Firefox 31 x64 Linux Mageia 4, 64bit, kde.
I have installed the packages gstreamer0.10 and gstreamer1.0 but the service is still on Youtube h.264 is not active, despite the detection of use h.264 at html5test.com
This happens on a PC, on a laptop with the same system and the same version of Firefox. everything works okay.

What is wrong?

List of pack gstreamer I have in system (maybe some is missing?)

[[root@localhost x]# rpm -qa|grep gstreamer
gstreamer1.0-plugins-ugly-1.2.2-1.mga4.tainted
gstreamer0.10-mpeg-0.10.19-9.mga4.tainted
phonon-gstreamer-4.6.3-2.mga4
gstreamer1.0-gstclutter-2.0.8-2.mga4
gstreamer1.0-amrnb-1.2.2-1.mga4.tainted
gstreamer1.0-soup-1.2.2-1.mga4
gstreamer0.10-tools-0.10.36-7.mga4
gstreamer1.0-pulse-1.2.2-1.mga4
gstreamer0.10-cdparanoia-0.10.36-7.mga4
gstreamer1.0-cdparanoia-1.2.2-1.mga4
gstreamer0.10-xvid-0.10.23-14.mga4.tainted
gstreamer1.0-gme-1.2.2-1.mga4.tainted
libgstreamer1.0_0-1.2.2-1.mga4
gstreamer1.0-farstream-0.2.3-3.mga4
gstreamer0.10-resindvd-0.10.23-14.mga4.tainted
gstreamer0.10-pulse-0.10.31-6.mga4
gstreamer0.10-voip-0.10.23-14.mga4.tainted
gstreamer1.0-a52dec-1.2.2-1.mga4.tainted
gstreamer1.0-twolame-1.2.2-1.mga4.tainted
gstreamer1.0-plugins-good-1.2.2-1.mga4
lib64gstreamer-plugins-base0.10_0-0.10.36-7.mga4
gstreamer0.10-ffmpeg-0.10.13-14.mga4
gstreamer1.0-wavpack-1.2.2-1.mga4
gstreamer0.10-musepack-0.10.23-14.mga4.tainted
gstreamer1.0-gsm-1.2.2-1.mga4.tainted
gstreamer1.0-plugins-bad-1.2.2-1.mga4.tainted
gstreamer0.10-plugins-bad-0.10.23-14.mga4.tainted
gstreamer1.0-tools-1.2.2-1.mga4
packagekit-gstreamer-plugin-0.8.14-3.1.mga4
gstreamer0.10-x264-0.10.19-9.mga4.tainted
gstreamer0.10-lame-0.10.19-9.mga4.tainted
gstreamer1.0-cdio-1.2.2-1.mga4.tainted
gstreamer1.0-flac-1.2.2-1.mga4
gstreamer0.10-plugins-ugly-0.10.19-9.mga4.tainted
gstreamer1.0-x264-1.2.2-1.mga4.tainted
gstreamer1.0-mms-1.2.2-1.mga4.tainted
gstreamer1.0-rtmp-1.2.2-1.mga4.tainted
gstreamer1.0-speex-1.2.2-1.mga4
gstreamer0.10-mms-0.10.23-14.mga4.tainted
lib64gstreamer0.10_0-0.10.36-7.mga4
gstreamer0.10-plugins-base-0.10.36-7.mga4
gstreamer1.0-soundtouch-1.2.2-1.mga4.tainted
gstreamer0.10-dirac-0.10.23-14.mga4.tainted
gstreamer1.0-plugins-base-1.2.2-1.mga4
lib64gstreamer-plugins-base1.0_0-1.2.2-1.mga4
gstreamer1.0-dv-1.2.2-1.mga4
gstreamer0.10-plugins-good-0.10.31-6.mga4
gstreamer1.0-lame-1.2.2-1.mga4.tainted
gstreamer1.0-libav-1.2.2-1.mga4
lib64gstreamer1.0_0-1.2.2-1.mga4
gstreamer1.0-mpeg-1.2.2-1.mga4.tainted]


Expected results:

I expect h.264 option will be active on YouTube. So it is not even though I have installed the required packages gstreamer1.0 and gstreamer0.10. I also have a set in about: config entry media.gstreamer, to true.

Updated

4 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core
Component: Audio/Video → Audio/Video: Playback
Priority: -- → P5
gstreamer is going in bug 1234092
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.