[settings] move root panel airplane mode item into panels/root

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: eragonj, Assigned: eragonj)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

Comment hidden (empty)
We have to move airplane mode related function into panels/root.
Created attachment 8480302 [details] [review]
patch on master
Attachment #8479716 - Attachment is obsolete: true
Comment on attachment 8480302 [details] [review]
patch on master

Arthur, please help me review this patch if you have time.

Thanks :)
Attachment #8480302 - Flags: review?(arthur.chen)
Comment on attachment 8480302 [details] [review]
patch on master

r=me with jsdoc added, thanks!
Attachment #8480302 - Flags: review?(arthur.chen) → review+
Thanks Arthur, just merged into Gaia/master : https://github.com/mozilla-b2g/gaia/commit/5567c7d0b4408032723231490ed7e7ba1a3e0dcf
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
something might got broken after rebase, so revert the patch first : https://github.com/mozilla-b2g/gaia/commit/7a33a9b7a2d1793d369ff2164fd0e40b5e047c1f
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 8484052 [details] [review]
patch on master (fix failed stuffs)

Arthur,

I updated the patch and added one more unit test for it, please help me review again, thanks.

Zac,

there are few changes for selectors, please help me review, thanks !
Attachment #8484052 - Flags: review?(zcampbell)
Attachment #8484052 - Flags: review?(arthur.chen)
Comment on attachment 8484052 [details] [review]
patch on master (fix failed stuffs)

Looks good to me! Thanks!
Attachment #8484052 - Flags: review?(arthur.chen) → review+
master: 91117b736b5a49dbc4cdab6a9a65b556a93f8a3e
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
revert: 74d19483b30e66d55e97da1a7eae8c605d7fe157

Sorry I did not notice that there was still a pending request.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8484052 [details] [review]
patch on master (fix failed stuffs)

one of the locators is wrong. The rest of the code LGTM
Attachment #8484052 - Flags: review?(zcampbell) → review-

Updated

4 years ago
Duplicate of this bug: 973470
Created attachment 8489198 [details] [review]
patch on master (with XPath fixed)

@Arthur, I created a new branch for this patch because the old one just got merged and reverted. There is no change in settings app but still need your r+.

@Bebe, I just fixed the XPath as you mentioned and waiting for CI, please help me review again.

Thanks all.
Attachment #8480302 - Attachment is obsolete: true
Attachment #8484052 - Attachment is obsolete: true
Attachment #8489198 - Flags: review?(florin.strugariu)
Attachment #8489198 - Flags: review?(arthur.chen)
Comment on attachment 8489198 [details] [review]
patch on master (with XPath fixed)

r=me, sorry about that. :p
Attachment #8489198 - Flags: review?(arthur.chen) → review+
Comment on attachment 8489198 [details] [review]
patch on master (with XPath fixed)

Because Bug 1067378 I can't test this pull on a device.

I manually check the locators and they look OK
Attachment #8489198 - Flags: review?(florin.strugariu) → review+
Thanks @Arthur & @Bebe, just merged this at https://github.com/mozilla-b2g/gaia/commit/a5f97cdbddacbaea9031aa9f9f00ab74cbcb25fc
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.