If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove reporting of the firefox release channel from the guided bug entry (hasn't been accurate since firefox 25)

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Extensions: GuidedBugEntry
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Peter Kroon, Unassigned)

Tracking

Production
x86
Windows 7

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140826030203

Steps to reproduce:

Filed a bug 


Actual results:

US is lsited as:

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140826030203

It's not a Beta/Release


Expected results:

Should display Nightly/Release

Updated

3 years ago
Assignee: nobody → ui
Component: Untriaged → User Interface
Product: Firefox → Bugzilla
QA Contact: default-qa
Version: 34 Branch → unspecified
Assignee: ui → nobody
Component: User Interface → Extensions: GuidedBugEntry
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production
the current logic has

  if (user agent contains "Gecko/20100101")
    Beta/Release
  else
    Nightly/Aurora

there appears to be a recent change to firefox's user agent which broke this.  i'm chatting with the fx devs to see if there are any other options available to us.
Status: UNCONFIRMED → NEW
Ever confirmed: true
it wasn't a recent change; the UA changed in firefox 25 (via bug 728773).

given it's been broken for so long, and there doesn't appear to be an easy way to detect it anymore, we should just remove it.
Summary: Wrong UA when filing BUG → Remove reporting of the firefox release channel from the guided bug entry (hasn't been accurate since firefox 25)
this fix for this was accidentally committed as part of http://git.mozilla.org/?p=webtools/bmo/bugzilla.git;a=commitdiff;h=2a9db67806fbc2483afce36e0660f03a99b5ec5f [github] instead of separately.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.