Always freeze the build ID in the UA string at 20100101

RESOLVED FIXED in mozilla25

Status

()

defect
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Dolske, Assigned: dao)

Tracking

({dev-doc-complete, site-compat})

Trunk
mozilla25
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
Bug 588909 seeks to change the UA string to use the release version instead of a frozen-or-not date. As of right now, that's looking to cause too much breakage and may not stick.

Currently (well, before the change in bug 588909), the Firefox Release and Beta channels have a frozen "Gecko/20100101" [sic] string (bug 591537), whereas Aurora and Nightly are still using a string with the actual build date. AIUI, that was done so support and nightly fans could easily check what version they're running (especially in the past when the UA was prominently shown in the About dialog).

I suggest that until bug 588909 is sorted out, we change Nightly and Aurora to use the same frozen "Gecko/20100101" string as Beta and Release already do. It's good to be consistent with what ultimately ships, and should be safe and non-controversial since Beta/Release already do this.

We probably want to hang some dependent bugs off this one, to show the actual build date in about:support / about:buildconfig / some other useful place. That will allow support and community to easily check it, without exposing it in the UA.

[Note that if bug 588909 gets sorted out, this bug is basically moot. My point isn't to prefer "Gecko/20100101" over "Gecko/13.0", but rather just to make an easy change to the status quo if bug 588909 gets delayed.]
FWIW, for consistency across channels, we could alternatively fix bug 728797 and that would fix Zimbra for us.

Comment 2

7 years ago
(In reply to Justin Dolske [:Dolske] from comment #0)
> We probably want to hang some dependent bugs off this one, to show the
> actual build date in about:support / about:buildconfig / some other useful
> place. That will allow support and community to easily check it, without
> exposing it in the UA.

Bug 589444.
Depends on: 589444
Assignee

Comment 3

6 years ago
The dynamic build ID continues to break sites. See http://forums.mozillazine.org/viewtopic.php?p=12993569#p12993569 and the following posts.

We should freeze it for nightly/aurora so testers will test what we ship to end users and we shouldn't let other Gecko applications differ in this regard either.
Summary: Nightly and Aurora should use the existing frozen "Gecko/20100101" UA string → Always freeze the build ID in the UA string at 20100101
Assignee

Comment 4

6 years ago
(In reply to Daniel Cater from comment #2)
> (In reply to Justin Dolske [:Dolske] from comment #0)
> > We probably want to hang some dependent bugs off this one, to show the
> > actual build date in about:support / about:buildconfig / some other useful
> > place. That will allow support and community to easily check it, without
> > exposing it in the UA.
> 
> Bug 589444.

The build date is exposed in the About window. about:buildconfig exposes the changeset which is already more accurate.
No longer depends on: 589444
Assignee

Comment 5

6 years ago
Posted patch 20100101.diffSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #783776 - Flags: superreview?(gerv)
Attachment #783776 - Flags: review?(bzbarsky)
I don't want to make this change until I'm sure that Support are happy with it. CCing ibai and mluna.

Gerv
Comment on attachment 783776 [details] [diff] [review]
20100101.diff

r=me
Attachment #783776 - Flags: review?(bzbarsky) → review+
Assignee

Comment 8

6 years ago
(In reply to Gervase Markham [:gerv] from comment #6)
> I don't want to make this change until I'm sure that Support are happy with
> it. CCing ibai and mluna.
> 
> Gerv

You mean end-user support aka SUMO? The build ID is already frozen for the users targeted there.
Agree with comment 8, we target Release user (and Beta to a certain extend) so we are not blocking this. We are good to go.

Thanks for looping us in.
Comment on attachment 783776 [details] [diff] [review]
20100101.diff

Review of attachment 783776 [details] [diff] [review]:
-----------------------------------------------------------------

OK, r=gerv on the principle of making Nightly and Aurora match Beta and Release.

Gerv

::: netwerk/protocol/http/nsHttpHandler.cpp
@@ -313,3 @@
>  #endif
> -    if (mProductSub.IsEmpty() && appInfo)
> -        appInfo->GetPlatformBuildID(mProductSub);

Can the GetPlatformBuildID function now be removed, or is it used elsewhere?
Attachment #783776 - Flags: superreview?(gerv) → superreview+
Assignee

Comment 11

6 years ago
(In reply to Gervase Markham [:gerv] from comment #10)
> Can the GetPlatformBuildID function now be removed, or is it used elsewhere?

It's part of nsIXULAppInfo and still used in JS. http://mxr.mozilla.org/mozilla-central/search?string=.platformBuildID
https://hg.mozilla.org/mozilla-central/rev/914a4d53edfb
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Reporter

Comment 14

6 years ago
Things I rarely say: "I am so happy we've finally made this change to the UA". <3

Updated

6 years ago
Duplicate of this bug: 817450

Comment 16

6 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20130805 Firefox/24.0

it is not fixed.

It needs to say:

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0
Vic, see the "Target Milestone" field of this bug?

Comment 18

6 years ago
adding dev-doc-needed keyword, it's probably worth to note in "Firefox 25 for developers"
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/25

and may be other docs needs to change
Keywords: dev-doc-needed
I'm not sure we need to note this in "Firefox 25 for developers" because nothing has changed on the Beta or Release channels.

Gerv
Assignee

Comment 20

6 years ago
(In reply to Gervase Markham [:gerv] from comment #19)
> I'm not sure we need to note this in "Firefox 25 for developers" because
> nothing has changed on the Beta or Release channels.

True. https://developer.mozilla.org/en-US/docs/Gecko_user_agent_string_reference also reflects this already.
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.