[WiFi Tethering] wifi tethering will not work when wifi STA and AP use different interface names

RESOLVED FIXED in Firefox 34, Firefox OS v2.0M

Status

Firefox OS
Wifi
--
major
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: seinlin, Assigned: seinlin)

Tracking

(Blocks: 1 bug)

unspecified
2.1 S3 (29aug)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0M+, firefox32 wontfix, firefox33 wontfix, firefox34 fixed, b2g-v2.0 wontfix, b2g-v2.0M fixed, b2g-v2.1 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
wifi tethering will not work when wifi STA and AP use different interface names.
(Assignee)

Comment 1

3 years ago
Created attachment 8480487 [details] [diff] [review]
bug-1059702-fix.patch

Vincent, I think having one more property "wifi.tethering.interface" for wifi AP interface could be an acceptable solution. When it doesn't exist, manager.ifname will be used(same flow as before). How do you think?
Attachment #8480487 - Flags: review?(vchang)
Comment on attachment 8480487 [details] [diff] [review]
bug-1059702-fix.patch

Review of attachment 8480487 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #8480487 - Flags: review?(vchang) → review+
(Assignee)

Comment 3

3 years ago
try result: https://tbpl.mozilla.org/?tree=Try&rev=eadc28f71b6f
Keywords: checkin-needed
(Assignee)

Comment 4

3 years ago
Jenny, We'll need this fix on 2.0M, without this wifi tethering will no work.
blocking-b2g: --- → 2.0M?
Flags: needinfo?(jeliu)

Updated

3 years ago
blocking-b2g: 2.0M? → 2.0M+
Flags: needinfo?(jeliu)
https://hg.mozilla.org/integration/b2g-inbound/rev/97a628a6657f
Assignee: nobody → kli
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/97a628a6657f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S3 (29aug)
(Assignee)

Comment 7

3 years ago
v2.0m: http://hg.mozilla.org/releases/mozilla-b2g32_v2_0m/rev/f49bddd694d1
(Assignee)

Updated

3 years ago
status-b2g-v2.0M: --- → fixed
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1061242
status-b2g-v2.0: --- → wontfix
status-b2g-v2.1: --- → fixed
status-firefox32: --- → wontfix
status-firefox33: --- → wontfix
status-firefox34: --- → fixed

Updated

3 years ago
Blocks: 1054172
You need to log in before you can comment on or make changes to this bug.