[RPP] Detecting, Setting and Storing the Password in the SettingsDB

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: marta, Assigned: wojciech.lakomy)

Tracking

({privacy})

unspecified
All
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
If the Password was not set the workflow for setting the password should be started. Password should be stored in a hashed for in the settings DB
Reporter

Updated

5 years ago
Blocks: 957977
Reporter

Updated

5 years ago
Summary: RPP: Setting and Storing the Password in the SettingsDB → [RPP] Setting and Storing the Password in the SettingsDB

Updated

5 years ago
Keywords: privacy

Updated

5 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → All
Reporter

Updated

5 years ago
QA Whiteboard: STATUS: engineering design
Priority: -- → P4
Reporter

Updated

5 years ago
QA Whiteboard: STATUS: engineering design → STATUS: not started
Reporter

Updated

5 years ago
Assignee: marta → wojciech.lakomy
Reporter

Comment 1

5 years ago
This is a merge between this bug and 1060152, due to overlapping functionality.
QA Whiteboard: STATUS: not started → STATUS: implementation work
No longer depends on: 1060152
Summary: [RPP] Setting and Storing the Password in the SettingsDB → [RPP] Detecting, Setting and Storing the Password in the SettingsDB
Reporter

Updated

5 years ago
Duplicate of this bug: 1060152
Reporter

Updated

5 years ago
QA Whiteboard: STATUS: implementation work → STATUS: ready for review
Priority: P4 → --

Comment 4

5 years ago
Patch tested. Following issues detected:
- taping 'ok' without entering any passphrase displays next screen
- taping the input field crashes application
Reporter

Updated

5 years ago
Blocks: 1069915
Reporter

Updated

5 years ago
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
feature-b2g: --- → 2.2+
You need to log in before you can comment on or make changes to this bug.