Closed Bug 1060229 Opened 7 years ago Closed 7 years ago

[bluedroid] Get/SetProperty DiscoveryTimeout failed due to missing property length

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.0M fixed, b2g-v2.1 unaffected)

RESOLVED FIXED
2.1 S3 (29aug)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed
b2g-v2.0M --- fixed
b2g-v2.1 --- unaffected

People

(Reporter: shawnjohnjr, Assigned: shawnjohnjr)

References

Details

Attachments

(2 files, 1 obsolete file)

SetProperty DiscoveryTimeout failed due to missing property length.
This will make bluedroid write value failed and given GKI interface warning.
Due to bt_property_t of value length is missing.
I'm not sure v2.1 is affected since v2.1 refactoring totally. Need to check again.
Comment on attachment 8481104 [details] [diff] [review]
Bug 1060229 - [bluedroid] Set DiscoveryTimeout failed due to missing prop length

Review of attachment 8481104 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8481104 - Flags: review?(btian) → review+
Summary: [bluedroid] SetProperty DiscoveryTimeout failed due to missing property length → [bluedroid] Get/SetProperty DiscoveryTimeout failed due to missing property length
blocking-b2g: --- → 1.4+
Assignee: nobody → shuang
Attachment #8481166 - Attachment description: Bug 1060229 - [bluedroid] Set DiscoveryTimeout failed due to missing prop length, r=btian → (v1.4) Bug 1060229 - [bluedroid] Set DiscoveryTimeout failed due to missing prop length, r=btian
This patch does not need to port bluetooth2 (BT API for v2.2).
https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/e364fb0b4346

If this needs to land on v2.0 as well, you'll need to request b2g32 approval on the patch.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(shuang)
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S3 (29aug)
Ben, does this need v2.0 uplift?
Flags: needinfo?(btian)
NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bluedroid back-end support
User impact if declined: MCTS Bluetooth test case fail to pass
Testing completed: 
Risk to taking this patch (and alternatives if risky): Low risk
String or UUID changes made by this patch: No
Attachment #8486179 - Flags: approval-mozilla-b2g32?
Flags: needinfo?(btian)
Hey Kevin/shawn, why was this blocked on 1.4? How does this impact 2.0 or what exactly is the user impact here? IS this a regression we are trying to fix ?  We do not want to add any risk on 2.0 at this point so please provide the comments on this being blocking the release.
Flags: needinfo?(khu)
Eric, can I have your comments here? Thanks!
Flags: needinfo?(khu) → needinfo?(echou)
Hi bhavana,
This will fix MCTS test case.
(In reply to Kevin Hu [:khu] from comment #11)
> Eric, can I have your comments here? Thanks!

I prefer picking this patch into 2.0. The main reason is because MCTS couldn't be passed without the patch. In addition the patch seems no harm to me (and not to mention this is a bug which might touch the invalid memory space).
Flags: needinfo?(echou)
Attachment #8486179 - Flags: approval-mozilla-b2g32? → approval-mozilla-b2g32+
See Also: → 1128441
Blocks: Woodduck
You need to log in before you can comment on or make changes to this bug.