Closed Bug 106065 Opened 20 years ago Closed 20 years ago

Can't invoke QuickTime Plug-In via <object>

Categories

(Core :: Plug-ins, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 46569

People

(Reporter: hsivonen, Assigned: serhunt)

References

()

Details

Build ID: 2001102205 FizzillaCFM, trunk

Reproducible: Always

Steps to reproduce:
1) Load the examples linked from http://www.hut.fi/~hsivonen/test/object/

Expected results:
Expected at least qt-in-object-with-data.html display an animation of a 3D
hourglass. Would be good if the other tests worked, too.

Actual results:
Only the test with non-standard <embed> fallback works. The tests with <object>
only don't work.

Additional info:
qt-in-object.html follows Apple's ActiveX sample but omits the non-standard
<embed> fallback. Expected Mozilla to use the QuickTime Plug-In instead of ActiveX.
Blocks: html4.01
Your HTML is not correct for Mozilla. You are trying to invoke an ActiveX
control by specifying a classid in your OBJECT tag that is not recognized by
Gecko. In order to use the OBJECT tag to invoke 4.x-style plugins, DO NOT
specify a classid attribute. Or, install an ActiveX compatibility plugin that
will be able to understand that your classid belongs to the Quicktime plugin.

*** This bug has been marked as a duplicate of 46569 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Reporter, please also note that the correct mime type for QT movies is 
'video/quicktime' not 'movie/quicktime' as specified in your test case.
Sorry. Fixing the media type fixed the case without the .cab reference.
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.