Last Comment Bug 7954 - (html4.01) outstanding issues for full HTML 4.01 support
(html4.01)
: outstanding issues for full HTML 4.01 support
Status: RESOLVED INCOMPLETE
: helpwanted, html4, meta
Product: Core
Classification: Components
Component: Tracking (show other bugs)
: Trunk
: All All
: P3 normal with 55 votes (vote)
: ---
Assigned To: Hixie (not reading bugmail)
: Hixie (not reading bugmail)
Mentors:
http://www.w3.org/TR/html401/
: 53899 (view as bug list)
Depends on: col-align-inherit character-alignment frame-longdesc 8131 18154 37209 option-label alttext 55623 57399 57882 88791 102915 103053 678 797 994 1044 1061 1312 1802 1882 metadata longdesc 2055 2068 2590 2634 2749 2750 2800 2970 3166 3248 3326 3687 basefont 4050 6306 6782 7112 7230 7304 7515 7559 7670 7834 8938 8979 text-dir 9140 10512 11229 11431 13015 13354 14088 14362 14445 15499 15545 15799 16157 Default-Quotes 17962 18357 18644 19312 20582 21076 21456 21638 22037 22480 22820 22842 24025 table-rules 24125 24366 24815 nested-quotes 25680 26282 26650 27828 27997 28293 28657 28823 30178 31451 32372 34297 34662 35700 35772 36790 36803 37083 zws 38761 39901 40623 object-codebase robin's 42180 42443 42532 42629 42753 44306 44396 44415 44465 45169 45375 45380 46475 46805 47078 47149 47163 47191 47522 47739 47760 47841 48256 48376 48445 50081 52433 53112 53908 53985 54119 54651 55285 55987 55995 56088 56253 57028 57478 57524 58197 58887 59087 60375 62046 63916 64107 70978 72249 75185 77279 79836 84564 LinkUI 91468 91927 94269 94798 95549 96579 96658 96804 96976 99063 102896 102906 102907 105556 105693 106065 107621 109806 127137 127798 147446 151993 153920 162993 164979 192077 196735 bearded-imagemap fieldset-eats-spaces 277738
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-10 18:00 PDT by ekrock's old account (dead)
Modified: 2016-06-28 09:53 PDT (History)
82 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description ekrock's old account (dead) 1999-06-10 18:00:16 PDT
This is a meta bug for tracking purposes only.  It "depends" on
individual outstanding bugs with HTML 4.0 compliance and is a way to track them
and to speed the documenting of any deviations, exceptions, or known bugs
which remain at release.

NOTE: This meta bug depends on individual HTML 4.0 compliance bugs, not the
other way around!  If you wish use this meta bug to track an individual HTML
4.0 bug, either make this bug depend on the individual bug, or in the individual
bug, use this bug # in the "bugs which depend on this bug" field.
Comment 1 ekrock's old account (dead) 1999-07-07 17:40:59 PDT
Setting to M15 as this is a [META] bug for tracking only.
Comment 2 ekrock's old account (dead) 2000-01-14 17:26:59 PST
Setting to M20 as this is a [META] bug for tracking only.
Comment 3 ekrock's old account (dead) 2000-04-17 12:38:16 PDT
Marking helpwanted and (since this is just a META tracking bug) reassigning to 
nobody@mozilla.org so I don't get cc:d on every dependency change on every bug.
Comment 4 ekrock's old account (dead) 2000-04-25 12:15:33 PDT
Changing QA contact to nobody@mozilla.org so I stop getting spammed.
Comment 5 ekrock's old account (dead) 2000-09-14 13:29:06 PDT
I'm the reporter for this bug, so I get email for every change on a dependent
bug. I'd like to stop getting this significant volume of email. Is there any way
a bug reporter can arrange to stop getting updates for a particular bug? If not,
would it be possible for someone who actually wants to get these updates to
create a replacement bug for this one with them as the reporter?

Very sorry for the trouble. I'm simply reporting and cc:d on so many reports
that I have to be careful to control flow in every way I can. Thanks for any
assistance!
Comment 6 Matthew Tuck [:CodeMachine] 2000-09-15 20:07:22 PDT
No there's no way to stop this, the RFE is at bug #17464.
Comment 7 Hixie (not reading bugmail) 2000-09-24 20:31:16 PDT
*** Bug 53899 has been marked as a duplicate of this bug. ***
Comment 8 Jerry Baker 2000-11-07 09:06:02 PST
CC'ing self
Comment 9 Jerry Baker 2000-11-07 09:54:14 PST
adding some
Comment 10 Hixie (not reading bugmail) 2001-01-04 16:15:46 PST
Taking responsability for tracking this...
Comment 11 vectro 2001-02-25 18:31:04 PST
Why is bug 2212 listed here? According to
http://www.w3.org/TR/html401/struct/tables.html, user argents are not required
to support the char= or charoff= attributes.

Not to say that bug 2212 shouldn't be fixed, but it's not required for HTML 4.01
compliance.
Comment 12 Matthew Tuck [:CodeMachine] 2001-02-25 18:44:35 PST
This bug already contains many bugs that aren't required for HTML compliance. 
That's why it's called "full HTML compliance".
Comment 13 Karl Ove Hufthammer 2001-03-31 04:12:38 PST
> This bug already contains many bugs that aren't required
> for HTML compliance. 
> That's why it's called "full HTML compliance".

Should this bug depend on bug #74073? I think so, ian@hixie.ch disagrees.
Comment 14 Diego Biurrun 2001-08-13 08:56:04 PDT
Added mozilla1.0 keyword since HTML 4.01 compliance is a design goal of mozilla.
Comment 15 Jerry Baker 2002-05-27 14:29:36 PDT
Mass removing self from CC list.
Comment 16 Jerry Baker 2002-05-27 14:53:48 PDT
Now I feel sumb because I have to add back. Sorry for the spam.
Comment 17 Russell O'Connor 2002-10-21 10:24:36 PDT
Should bug 10512 be added?

Then again the comments in 10512 indicate the mozilla team isn't intersted in
full HTML 4.01 support.
Comment 18 Jacek Piskozub 2002-10-21 10:38:01 PDT
Same story with the WONTFIXed basefont bug 3875.
Comment 19 David G King 2002-10-21 12:12:38 PDT
Based on reading the bugs referenced by Comment #17 and Comment #18, where it is
stated by Mozilla/Netscape that 100% HTML 4.01 support is not going to happen, I
really don't see the purpose of this META tracking bug. It seems obsolete, or
end-of-lined, and thus should be marked WONTFIX.
Comment 20 Michael Lefevre 2002-10-27 11:22:12 PST
just because it's not going to be 100%, doesn't mean it isn't worth tracking
exactly which bits aren't compliant and whether they are going to be fixed or not.
Comment 21 Russell O'Connor 2002-12-15 16:37:26 PST
It seems that Mozilla isn't interested in HTML 4.01 support

According to comments in bug #692032 Mozilla isn't an XHTML user agent either. 
In particular ``XHTML isn't part of the current, official Mozilla agenda''.

So I'm curious to know what goals are Mozilla pursuing?  ISO/IEC 15445 perhaps?
 Maybe Mozilla isn't actually an HTML user agent?

I suppose this isn't the correct forum to be rasing these concerns.
Comment 22 Jacek Piskozub 2003-01-24 23:31:35 PST
Russel: We don't have #692032 bug, yet. Luckily. 

Which bug do you refer to?
Comment 23 Russell O'Connor 2003-01-27 10:47:56 PST
Sorry, It's bug #69032.

Apperently Mozilla isn't an HTML UA, it isn't an XHTML UA, it is supposed to be
an XML (+DOM +CSS) UA.

Well, the goals of Mozilla seems to vary from place to place, and from person to
person.
Comment 24 Anne (:annevk) 2004-08-20 07:50:18 PDT
Removing [META]. We have keywords for that.
Comment 25 Justin Kerk 2004-09-20 11:44:42 PDT
Should bug 3655 be on here?
Comment 26 Michael Newton 2005-01-06 13:52:02 PST
bug 189643 ? (see bug 1882 for discussion on standards compliancy)
Comment 27 Lars Gunther 2010-11-07 05:55:51 PST
Five and a half years later an update. Shouldn't this bug be closed now that we have HTML5?
Comment 28 Matěj Cepl 2010-11-07 11:49:19 PST
(In reply to comment #27)
> Five and a half years later an update. Shouldn't this bug be closed now that we
> have HTML5?

No, HTML5 is just a superstructure over HTML4, so without that being properly implemented, we are missing in HTML5 arena as well.
Comment 29 Hixie (not reading bugmail) 2010-11-07 12:05:37 PST
That's incorrect. HTML5 did not take HTML4 into account and is not a superset.
Comment 30 Jerry Baker 2010-11-07 13:21:49 PST
Regardless, Firefox needs to support HTML 4 for quite some time if it wants to remain a browser to be taken seriously.
Comment 31 Lars Gunther 2010-11-07 14:13:00 PST
There are 70+ users following this bug who do not want to lsiten in on a debate about the true nature of HTML5 and HTML 4. The question was, do Mozilla need to have this bug open? I was trying to help closing no longer needed bugs.

HTML 4 is supported BY supporting HTML 5. There is only one HTML parser in Firefox and there is only one DOM tree. Firefox has switched to an HTML5 compliant parser. So is this bug helpful to keep track of stuff to implement, or are there better ways?
Comment 32 Jacek Piskozub 2010-11-07 14:31:53 PST
This is a tracking bug and 22 bugs it tracks are still open. This more or less should end this unnecessary discussion.
Comment 33 sunnybunny8920 2016-05-02 16:57:48 PDT Comment hidden (spam)
Comment 34 Benjamin Smedberg [:bsmedberg] 2016-06-28 09:52:50 PDT
This bug is no longer being used to track/prioritize engineering work, so I'm going to close it out.

Note You need to log in before you can comment on or make changes to this bug.