Closed Bug 1060725 Opened 8 years ago Closed 8 years ago

Audit test coverage of ICE contacts

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

defect
Not set
normal

Tracking

(b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S4 (12sep)
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: drs, Assigned: drs)

References

Details

Attachments

(1 file)

Our test coverage for ICE contacts within the emergency-call app needs to be audited as we suspect that there are some tests missing.
Whiteboard: [dialer-most-wanted] → [planned-sprint]
Assignee: nobody → drs+bugzilla
Target Milestone: 2.1 S4 (12sep) → 2.1 S5 (26sep)
Status: NEW → ASSIGNED
Whiteboard: [planned-sprint]
Target Milestone: 2.1 S5 (26sep) → 2.1 S4 (12sep)
PR: https://github.com/mozilla-b2g/gaia/pull/23871

The test coverage was actually pretty good, but I didn't like how the file was structured. Each test now has its own sandboxed HTML.
Attachment #8486613 - Flags: review?(anthony)
Comment on attachment 8486613 [details] [diff] [review]
Add missing tests to ICEContacts.

Review of attachment 8486613 [details] [diff] [review]:
-----------------------------------------------------------------

We're missing tests for our error screens. I'm still giving r+ because I think we can do this in bug 1060451. But maybe you want to write some in this patch. Up to you.
Attachment #8486613 - Flags: review?(anthony) → review+
https://github.com/mozilla-b2g/gaia/commit/cebd0464aa9bb5e67fabf352042f38df4e1c1b84
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 8486613 [details] [diff] [review]
Add missing tests to ICEContacts.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Not a bug, asking for uplitfing since this bug just adds more unit tests, and having this bug in 2.1 will solve merge conflicts with bug 1061421 that has been already approved for 2.1
[User impact] if declined:
Will need to rewrite the patch for 2.1. Not user, but developer inpacted ;P
[Testing completed]:
This bug adds more unit tests and have been in 2.2 for a while
[Risk to taking this patch] (and alternatives if risky):
Pretty low risk, checked with Dialer guys and adds more tests, which will increase confident in 2.1 release
[String changes made]:
Attachment #8486613 - Flags: approval-gaia-v2.1?
Attachment #8486613 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1?(bbajaj)
Attachment #8486613 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
Depends on: 1069439
You need to log in before you can comment on or make changes to this bug.