ICE contacts don't show up on emergency call screen

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Dialer
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: drs, Assigned: drs)

Tracking

({regression})

unspecified
2.1 S5 (26sep)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

4 years ago
[Blocking Requested - why for this release]: ICE contacts don't show up on emergency call screen.
blocking-b2g: --- → 2.1?
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Keywords: regression
(Assignee)

Comment 2

4 years ago
Created attachment 8491664 [details] [diff] [review]
Fix ICE contacts not showing up on emergency call screen.

PR: https://github.com/mozilla-b2g/gaia/pull/24193

The PR has this unrolled into a series of commits if you want better structure. A lot of it is just cleanup.
Attachment #8491664 - Flags: review?(anthony)
Adding qawanted for branch checks.
Keywords: qawanted
(Assignee)

Comment 4

4 years ago
(In reply to KTucker [:KTucker] from comment #3)
> Adding qawanted for branch checks.

That's not necessary. We're certain that this was caused by bug 1060725, so it must exist on v2.1 and master.
Keywords: qawanted
Triage: broken 2.1 feature.
blocking-b2g: 2.1? → 2.1+
Comment on attachment 8491664 [details] [diff] [review]
Fix ICE contacts not showing up on emergency call screen.

Review of attachment 8491664 [details] [diff] [review]:
-----------------------------------------------------------------

I left some nits in the pull request.
Attachment #8491664 - Flags: review?(anthony) → review+
(Assignee)

Comment 7

4 years ago
https://github.com/mozilla-b2g/gaia/commit/d8f14755e9fc8e4bc260aa8ed961b81ae6884943
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED
(Assignee)

Comment 8

4 years ago
Request uplift tomorrow.
Flags: needinfo?(drs+bugzilla)
(Assignee)

Comment 9

4 years ago
Comment on attachment 8491664 [details] [diff] [review]
Fix ICE contacts not showing up on emergency call screen.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1060725
[User impact] if declined: ICE contacts will not appear on emergency call screen.
[Testing completed]: Anthony and I tested this.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Attachment #8491664 - Flags: approval-gaia-v2.1?(release-mgmt)
Flags: needinfo?(drs+bugzilla)
Attachment #8491664 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1+

Comment 11

4 years ago
issue has been verified fixed on, Flame 2.2 Master KK (319mb) (Full Flash) and Flame 2.1 Master KK (319mb) (Full Flash) 

the ICE contact now shows up on the emergency call screen on both versions

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

2.1 KK (319mb) (Full Flash)

Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
Build ID: 20141010000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Version: 34.0a2 Flame 2.1 KK (319mb)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: qa
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: qa → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.