Closed Bug 1060727 Opened 6 years ago Closed 6 years ago

[CMAS] Duplicated notifications in system tray when dismiss the attention screen by tapping on home button

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: steveck, Assigned: steveck)

References

Details

Attachments

(2 files)

46 bytes, text/x-github-pull-request
azasypkin
: review+
Details | Review
2.70 MB, video/mp4
Details
Since new attention screen (Bug 927862) landed recently, we address some fixing in bug 1051795 to make this alert attention screen works correctly, but we will still need to deal with the home button behavior.

Reproduce step:
1) Receive alert and display attention screen
2) Tap home screen, attention will scroll and resize to top and dismiss after a timeout(new attention screen behavior).
3) Swipe down system tray, you could see a new "tap here" notification (new attention screen behavior) and the original alert notification. But click on original alert notification could not work. We will need to just keep one of the notification(maybe keep the original one, but it's UX call) 

Hi Jenny, could you please update the spec for this changes?
Confirmed with Jenny, CMAS attention screen will close and leave the normal(removable) notification when tapping on home button instead of keeping a fixed "tap here" notification in system tray. Since this bug didn't block CMAS feature usability, remove the dependency from CMAS meta.
No longer blocks: cmas-application
Assignee: nobody → schung
Attached file Link to github
Hi Oleg, this patch closes the window to prevent the system creates a fixed notification, and makes the original one accessible. I also add some checking that only close the app while home key pressed, but any other thoughts are welcome!
Attachment #8482309 - Flags: review?(azasypkin)
Comment on attachment 8482309 [details] [review]
Link to github

Hey Steve,

I've left on Github only one concern regarding to "window.opener.close" vs several attention windows at the same time, but if you think that it's rare case then r=me!

Thanks!
Comment on attachment 8482309 [details] [review]
Link to github

As we agreed, we'll file a follow-up to correctly handle multiple attention windows, so r=me here.

Thanks!
Attachment #8482309 - Flags: review?(azasypkin) → review+
Thanks for the review! ni myself to create a follow-up bug for dealing with multiple alert attention window later.

master : 52f9bffb3f73c2435914f1ed50ac116d8d7b0d67
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(schung)
Resolution: --- → FIXED
[Blocking Requested - why for this release]:
Wrong UX behavior when alert attention screen dismissed by pressing home button. Two notification exists in system tray for one CMAS message, but only one of them could work.
blocking-b2g: --- → 2.1?
Flags: needinfo?(schung)
triage: CMAS is important new feature, and this defect makes user confusing.
blocking-b2g: 2.1? → 2.1+
Please request Gaia v2.1 approval on this patch when you get a chance.
Flags: needinfo?(schung)
Target Milestone: --- → 2.1 S4 (12sep)
Comment on attachment 8482309 [details] [review]
Link to github

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): left over from new v2.1 feature bug 1026685
[User impact] if declined: user will see duplicated notifications in system tray when attention screen is dismissed by home button tap
[Testing completed]: unit tests
[Risk to taking this patch] (and alternatives if risky): low, + Network Alerts is new app for v2.1
[String changes made]: n/a
Attachment #8482309 - Flags: approval-gaia-v2.1?
Flags: needinfo?(schung)
Attachment #8482309 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Attached video verify_video.MP4
This issue has been verified successfully on Flame 2.1/2.2, there is only one notification shown when swipe down system tray.
See attachment:verify_video.MP4

Flame 2.1 build:
Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f05d0a2d2378
Build-ID        20150120001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150120.035022
FW-Date         Tue Jan 20 03:50:33 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5d7497ce4cc7
Build-ID        20150120002507
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150120.035540
FW-Date         Tue Jan 20 03:55:51 EST 2015
Bootloader      L1TC000118D0
According to Comment 11,change the status.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.