Closed Bug 1051795 Opened 6 years ago Closed 6 years ago

[CMAS] Handle the setting that enables/disables CMAS alerts

Categories

(Firefox OS Graveyard :: Gaia::Network Alerts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.1, tracking-b2g:backlog)

RESOLVED FIXED
2.1 S3 (29aug)
feature-b2g 2.1
tracking-b2g backlog

People

(Reporter: julienw, Assigned: steveck)

References

Details

(Whiteboard: [p=1])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
azasypkin
: review+
Details | Review
In this bug, well handle the setting that enables and disabled CMAS alerts.

We'll also possibly need to disable CMAS alerts in the System app, in the existing Cell Broadcast subsyste.
Target Milestone: --- → 2.1 S3 (29aug)
Depends on: 1032651
blocking-b2g: --- → backlog
feature-b2g: --- → 2.1
Whiteboard: [p=1]
Assignee: nobody → schung
Confirmed with EM/EPM, and this can be landed before FL.
Attached file Link to github
Hi Oleg, this should be the last CMAS feature in this sprint and I added the settings check and some other fixing. Thanks for all the efforts for CMAS feature :)
Attachment #8481160 - Flags: review?(azasypkin)
Hey Steve,

In code everything looks great, but as I mentioned on Github, something has changed very recently and our "attention" screen is closed right after it was opened. If I haven't messed up with bessicting, looks like recently landed patch for Bug 927862 changed system behaviour
(In reply to Oleg Zasypkin [:azasypkin] from comment #3)
> Hey Steve,
> 
> In code everything looks great, but as I mentioned on Github, something has
> changed very recently and our "attention" screen is closed right after it
> was opened. If I haven't messed up with bessicting, looks like recently
> landed patch for Bug 927862 changed system behaviour

Yeah I think it's because of Bug 927862 changes... 

Anyway I updated the patch per your comments, and I also changed the behvior here that don't close the window while attention screen show up, but close parent window while confirm button submitted.
Flags: needinfo?(azasypkin)
(In reply to Steve Chung [:steveck] from comment #4)
> (In reply to Oleg Zasypkin [:azasypkin] from comment #3)
> > Hey Steve,
> > 
> > In code everything looks great, but as I mentioned on Github, something has
> > changed very recently and our "attention" screen is closed right after it
> > was opened. If I haven't messed up with bessicting, looks like recently
> > landed patch for Bug 927862 changed system behaviour
> 
> Yeah I think it's because of Bug 927862 changes... 
> 
> Anyway I updated the patch per your comments, and I also changed the behvior
> here that don't close the window while attention screen show up, but close
> parent window while confirm button submitted.

Thanks a lot Steve, looking into it right now!
Flags: needinfo?(azasypkin)
Comment on attachment 8481160 [details] [review]
Link to github

Now it's great, r=me! I've left small comment on Github about the case when window.opener can be null.

Thanks for the all efforts!
Attachment #8481160 - Flags: review?(azasypkin) → review+
Blocks: 1060727
Thanks for the review! Some js integration error here but not relate to this app...
in master : eb34271edb00469d91d81e4398749632e97dd0b6
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Component: Gaia::SMS → Gaia::Network Alerts
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.