Enable e10s Linux opt browser chrome tests

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: billm, Assigned: jimm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8482020 [details]
enable-e10s-bc

Once the dependent bugs land, we should be green enough to start running browser-chrome tests on Linux opt.
(Reporter)

Comment 1

3 years ago
Created attachment 8482052 [details] [diff] [review]
enable-e10s-bc v2

RyanVM pointed out that we can enable on ASAN too since it doesn't do window leak detection.
Attachment #8482020 - Attachment is obsolete: true
(Assignee)

Comment 2

3 years ago
Comment on attachment 8482052 [details] [diff] [review]
enable-e10s-bc v2

Review of attachment 8482052 [details] [diff] [review]:
-----------------------------------------------------------------

Looking good on holly. I retriggered 5 times for each set. Ryan, how's your comfort level here with turning these on?

https://tbpl.mozilla.org/?tree=Holly
Attachment #8482052 - Flags: review?(ryanvm)
(Assignee)

Comment 3

3 years ago
looks like we can turn on debug as well, lets see how the retriggers come out.
Looks like it causes bug 945182 to make a not-so-triumphant return ~50% of the time? :(
Comment on attachment 8482052 [details] [diff] [review]
enable-e10s-bc v2

Review of attachment 8482052 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like debug hits a few leaks here and there, but opt looks good to me.
Attachment #8482052 - Flags: review?(ryanvm) → review+
(Assignee)

Updated

3 years ago
Assignee: nobody → jmathies
(Assignee)

Updated

3 years ago
Attachment #8482052 - Flags: review+ → feedback+
(Assignee)

Updated

3 years ago
Attachment #8482052 - Flags: review?(armenzg)
Comment on attachment 8482052 [details] [diff] [review]
enable-e10s-bc v2

Review of attachment 8482052 [details] [diff] [review]:
-----------------------------------------------------------------

It looks good to me.
https://tbpl.mozilla.org/?tree=Holly&jobname=e10s
Attachment #8482052 - Flags: review?(armenzg) → review+
(Assignee)

Comment 7

3 years ago
https://hg.mozilla.org/build/buildbot-configs/rev/82429c54883f

thanks for the help guys!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Hmm, I may have jumped the gun, bug 1061014 is required for this, and its still on inbound.
(Assignee)

Comment 9

3 years ago
(In reply to Jim Mathies [:jimm] from comment #8)
> Hmm, I may have jumped the gun, bug 1061014 is required for this, and its
> still on inbound.

sorry - bug 1060620
It is best to back out and wait until Monday when the changes will most likely be merged into all other trunk trees.

Mind backing out if it works for you?
It's highly likely that inbound will be merged to m-c before the next reconfig.
(Keeping open until it gets into the masters)

What about trees like fx-team or even people pushing their local checkouts to try?

If Ryan is happy, I'm happy as well.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
m-c is merged back around to the integration trees as soon as all the merges to m-c are completed. As for local trees, I don't see why that'd be any different than with any other tests regardless of timing.
(Assignee)

Updated

3 years ago
Blocks: 1063426
(Assignee)

Updated

3 years ago
Depends on: 1063417
(Assignee)

Comment 14

3 years ago
Did we miss something here, on inbound I see bc red runs, with

https://tbpl.mozilla.org/php/getParsedLog.php?id=47474750&tree=Mozilla-Inbound&full=1

Required config file not set! (use --config-file option)
program finished with exit code 255
Created attachment 8484954 [details] [diff] [review]
e10s.diff

We forgot this.
I'm asking coop for a reconfig for it.
Comment on attachment 8484954 [details] [diff] [review]
e10s.diff

r=coop
https://hg.mozilla.org/build/buildbot-configs/rev/04cc9fbd7e15

The reconfig will come in 30 mins.
Attachment #8484954 - Flags: review+
Merged to production, and deployed.
Jobs are running green, thanks!
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

3 years ago
Thanks for the help!
You're welcome!
Thanks coop!
You need to log in before you can comment on or make changes to this bug.