Closed Bug 1061068 Opened 8 years ago Closed 8 years ago

[Contacts] ICE missing from top of the list when toggling the 'Order by last name'

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: ericcc, Assigned: arcturus)

References

Details

(Whiteboard: [p=2])

Attachments

(2 files)

### STR
1. Have some contact entries in Contacts.
2. Set ICE contact and the ICE contact should appears on top of the list.
3. Tap 'Order by last name' from Settings.
4. Back to list

### Actual
ICE is missing from list

### Version
Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
BuildID   20140831160203
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
[Blocking Requested - why for this release]: Broken functionality
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=Gaia::Contacts]
Assignee: nobody → francisco
Whiteboard: [p=2]
Target Milestone: --- → 2.1 S4 (12sep)
Status: NEW → ASSIGNED
Attached file Pointer to PR 23633
Attachment #8482737 - Flags: review?(sergi.mansilla)
r+ and merged at af04d8bc2111d4ea146239a89ff602206b85eaf5
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Attachment #8482737 - Flags: review?(sergi.mansilla) → review+
major issue to new feature
blocking-b2g: 2.1? → 2.1+
Not working in 2.1
Gecko: 06f3a69
Gaia: 47939f4
Is not working in 2.1 cause it's not been uplifted, can yo confirm in 2.2?
Tested and working 
2.2
Flame
Gecko: cce3dff
Gaia: 879bd62
Please request Gaia v2.1 approval on this when you get a chance.
Flags: needinfo?(francisco)
Comment on attachment 8482737 [details] [review]
Pointer to PR 23633

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Feature ICE Contacts
[User impact] if declined:
Bad user experience, list of ice contacts will dissapear and until we relaunch the app wont be visible
[Testing completed]:
Verified in 2.2
[Risk to taking this patch] (and alternatives if risky):
Pretty low risk patch
[String changes made]:
Attachment #8482737 - Flags: approval-gaia-v2.1?(fabrice)
Flags: needinfo?(francisco)
Attachment #8482737 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Tested and working
2.1
Gecko-bdd77c4
Gaia-b3f9b97
Status: RESOLVED → VERIFIED
Verified as fixed for the latest 2.1 and 2.2 Flame builds:

Environmental Variables:
----------------------------------------
Device: Flame 2.2 Master
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Environmental Variables:
----------------------------------------
Device: Flame 2.1
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

'ICE Contacts' appear at the top of the contacts page when order is set to last name.
QA Whiteboard: [COM=Gaia::Contacts] → [COM=Gaia::Contacts][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Gaia::Contacts][QAnalyst-Triage?] → [COM=Gaia::Contacts][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
See Also: → 1157167
You need to log in before you can comment on or make changes to this bug.