[Flame][Contacts]ICE contacts icon will disappear in contacts list page after user sets "Order by last name".

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: xiongfuchao, Assigned: arcturus)

Tracking

({regression})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

Posted video video_1454.mp4
[1.Description]:
[Flame][v2.2 & v3.0][Contacts]If user sets 1 or 2 contact as ICE contact, ICE contact icon will appear on top of contact list. Then user sets "Oder by last name" from contact setting, ICE contact icon will disappear,and can't recove, but user can find ICE contact has been set successfully in contacts setting.
Found time:14:54
See attachment:logcat_1454.txt & video_1454.mp4

[2.Testing Steps]: 
Prerequisite:at least two contact in the contact list.
1.Open contacts app.
2.Tap setting icon and set an ICE contact.
3.Tap done.
4.Tap setting icon and set "Oder by last name".
5.Tap done, then check top of contact list.

[3.Expected Result]: 
5.There is an ICE contact icon on top of contact list.

[4.Actual Result]: 
5.No ICE contact icon displays.

[5.Reproduction build]: 
Flame 2.2(affected):
Build ID               20150421002501
Gaia Revision          828dd03a0e3b140d74b2e49355197df4d91d9227
Gaia Date              2015-04-20 18:28:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/36f72a3efb9b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.041828
Firmware Date          Tue Apr 21 04:18:39 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(affected):
Build ID               20150421160203
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/86725d1a2cf3
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.192130
Firmware Date          Tue Apr 21 19:21:42 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Posted file logcat_1454.txt
According to this, it should be fixed in 2.1 and 2.2(was master at that time), but that is broken again.
https://bugzilla.mozilla.org/show_bug.cgi?id=1061068#c13

NI RD for info.
Flags: needinfo?(francisco)
See Also: → 1061068
triage: blocking because it breaks function
blocking-b2g: --- → 2.2+
Franciso, given the above comments and since every blocker needs to have an assignee, I am passing this to you for now, please feel free to reassign as necessary. Thanks!
Assignee: nobody → francisco
Status: NEW → ASSIGNED
Flags: needinfo?(francisco)
Comment on attachment 8599296 [details] [review]
[gaia] arcturus:bug-1157167 > mozilla-b2g:master

It turn out to not to be a cache problem.

We were not cleaning a flag to allow to reload the ice information.
Attachment #8599296 - Flags: review?(ferjmoreno)
Comment on attachment 8599296 [details] [review]
[gaia] arcturus:bug-1157167 > mozilla-b2g:master

Easy one. Thanks!
Attachment #8599296 - Flags: review?(ferjmoreno) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/97890570862161049e1f33510e0696d55c735859
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8599296 [details] [review]
[gaia] arcturus:bug-1157167 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Regression
[User impact] if declined:
Data loss
[Testing completed]:
Tested on master
[Risk to taking this patch] (and alternatives if risky):
Pretty low
[String changes made]:
None
Attachment #8599296 - Flags: approval-gaia-v2.2?
Attachment #8599296 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Issue verified fixed on Flame 2.2 and 3.0

With ICE Contacts set, enabling order by last name in contacts does not cause ICE Contacts icon to disappear on contacts list.

Device: Flame 2.2
Build ID: 20150501002503
Gaia: 209bf4d6fcb16ea6834b8bd86976c012e5914fe6
Gecko: 79e7065ceefa
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
Build ID: 20150501010203
Gaia: 759a1f935a6a81c32ad66e39a6353b334dfa4f91
Gecko: 7723b15ea695
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.