Closed Bug 1061296 Opened 5 years ago Closed 5 years ago

[calendar] month view: Localized 'All day' label overlaps event's title/name

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: aryx, Assigned: evanxd)

References

Details

Attachments

(4 files)

Boot2Gecko 2.1.0.0-prerelease 20140830221627 on Geeksphone Keon

In the month view, the localized 'All day' label can overlap the event's title (e.g. for German which has only one character more than English).
can you provide a screenshot? I was not able to reproduce it on my Flame or Hamachi.

maybe you have the wrong fonts? https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/Flame#Font_fix

Here is a list of all translations for "All Day": http://transvision.mozfr.org/string/?entity=apps/calendar/calendar.properties:hour-allday&repo=gaia
Flags: needinfo?(archaeopteryx)
Attached image screenshot of issue
(In reply to Miller Medeiros [:millermedeiros] from comment #1)
> maybe you have the wrong fonts?
> https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/
> Flame#Font_fix
I neither use the Flame (but the Keon) nor do I use a custom build.
Flags: needinfo?(archaeopteryx)
this is definitely not supposed to happen... can you provide the BuildId, Platform-version and commit?

your screenshot also looks wrong because the blue line under the "Dienstag, 2. September" is supposed to cover the whole area; you have a weird glitch on the "Dienstag" and a weird background color on the event as well.
Flags: needinfo?(archaeopteryx)
Attached image month_2.0_de.png
screenshot from my hamachi running latest 2.0 (we did not change the month view on 2.1)
Attached image flame_2.1_de.png
was able to reproduce on latest build on Flame:

Gaia      44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko     https://hg.mozilla.org/mozilla-central/rev/c360f3d1c00d
BuildID   20140902040205
Version   34.0a1

will try to identify the cause/window.
Flags: needinfo?(archaeopteryx)
[Blocking Requested - why for this release]: looks like a regression from 2.0, bad UX.
blocking-b2g: --- → 2.1?
Assignee: nobody → mmedeiros
(In reply to Miller Medeiros [:millermedeiros] from comment #3)
> this is definitely not supposed to happen... can you provide the BuildId,
> Platform-version and commit?
Boot2Gecko 2.1.0.0-prerelease 20140831221650
Commit e7d31f0e (2014-08-31 19:51:06)

> your screenshot also looks wrong because the blue line under the "Dienstag,
> 2. September" is supposed to cover the whole area; you have a weird glitch
> on the "Dienstag" and a weird background color on the event as well.
Yes, there are graphical glitches in the Calendar app (not in general on the system), especially black boxes when panning the Add Event dialog. This is likely related to the fact that the phone is an older model.
(In reply to Archaeopteryx [:aryx] from comment #7)
> (In reply to Miller Medeiros [:millermedeiros] from comment #3)
> > your screenshot also looks wrong because the blue line under the "Dienstag,
> > 2. September" is supposed to cover the whole area; you have a weird glitch
> > on the "Dienstag" and a weird background color on the event as well.
> Yes, there are graphical glitches in the Calendar app (not in general on the
> system), especially black boxes when panning the Add Event dialog. This is
> likely related to the fact that the phone is an older model.

the black boxes is probably related to Bug 1060006 (also happens on Flame)
Target Milestone: --- → 2.1 S4 (12sep)
this was introduced by the Bug 1054178 patch. More specifically the changes to the month.css file (https://github.com/mozilla-b2g/gaia/commit/cdb162a7#diff-97fc6ca16b5c17dc4a50b0f66d672f05L249).
Blocks: 1054178
No longer blocks: 1027360
regression caused by 24hr dependency that was done last sprint.
blocking-b2g: 2.1? → 2.1+
Assignee: mmedeiros → evanxd
QA Whiteboard: [COM=Gaia::Calendar]
QA Contact: edchen
Hi Harly,

We need UX input here.
Could you provide the layout design of the event list view for the 12/24 hour format?

Thanks.
whatever we do, we can't forget about different locales - to be honest using the same width for 12/24h makes a lot of sense to me (like we had before), since "All day" is large string in some languages (http://transvision.mozfr.org/string/?entity=apps/calendar/calendar.properties:hour-allday&repo=gaia)
Flags: needinfo?(hhsu)
Yes, after knew this bug, I agree with Miller's option.
Sorry,
=> agree with Miller's opinion.
Yes, I agree with Miller's opinion as well. Me & Peko & Evan had an offline discussion, let's change back to our original design and use the same width for 12/24h. Thanks
Flags: needinfo?(hhsu)
Comment on attachment 8484030 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23702

Hi Miller,

We go back to origin design.
Could you help to review the patch?

Thanks.
Attachment #8484030 - Flags: review?(mmedeiros)
Comment on attachment 8484030 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23702

LGTM. small CSS change and same layout as before. fixes the problem
Attachment #8484030 - Flags: review?(mmedeiros) → review+
Thanks, Miller.
Comment on attachment 8484030 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23702

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1054178
[User impact] if declined: 'All day' label overlaps event's title/name when user sets language settings as German(or other languages if their 'All day' label is too long).
[Testing completed]: Local looks good, and the TBPL job[1] is passed.
[Risk to taking this patch] (and alternatives if risky): Low rick, we just change 7 lines of css.
[String changes made]: None

[1] https://tbpl.mozilla.org/?rev=8bd498d4438d2c06db843e16c7d3f269a4856c1a&tree=Gaia-Try
Attachment #8484030 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8484030 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
[Environment]
Gaia      944e5b4582c4efa1b67cd33245dbb8f6aa25d09f
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/7546fedad918
BuildID   20140914160203
Version   34.0a2
ro.build.date   Fri Jun 27 15:57:58 CST 2014
ro.bootloader   L1TC00011230
ro.build.version.incremental   110


[Result]
PASS
Status: RESOLVED → VERIFIED
This issue is verfied fixed for the Flame 2.2 Master (319mb) and the Flame 2.1 KK (319mb)

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result: The German local text is no longer overlapping in the calendar.
QA Whiteboard: [COM=Gaia::Calendar] → [QAnalyst-Triage?], [COM=Gaia::Calendar]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?], [COM=Gaia::Calendar] → [QAnalyst-Triage+], [COM=Gaia::Calendar]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.