Closed Bug 1061463 Opened 8 years ago Closed 8 years ago

Call log info must not reuse the string "Missed"

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: tchevalier, Assigned: thills)

References

Details

(Keywords: late-l10n, Whiteboard: [planned-sprint])

Attachments

(3 files)

The string "Missed" used in Call information screen is the same string used in tabs of the main call log view (All | Missed), and that doesn't work.

In French for instance, the Missed in tab is a plural, while the Missed in call info is singular.

The reused string I'm referring to is the one on the last two screenshots on page 5 of https://wiki.mozilla.org/images/c/c7/Call_length_in_Call_log.pdf

As a general rule of thumb, don't reuse strings in different contexts, see https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_best_practices#Don%27t_reuse_strings_in_different_contexts

Also, kudos if we can get some localization comments in the file, all those "Missed" "Canceled", "Incoming" "Outgoing" are really confusing, and that's hard to find out the exact context to translate properly :/

We are in FL, so adding late-l10n here.
Whiteboard: [planned-sprint]
Target Milestone: --- → 2.1 S4 (12sep)
Assignee: nobody → thills
Hi Theo,

I'm adding the extra string and wanted to understand what the process is since we have this late-l10n flag.  

When we land this, which .properties files (besides en-us) needs to have the key created?  If we need to add it to the other languages .properties files, do we need to obtain those strings before landing?

Thanks in advance,

-tamara
Status: NEW → ASSIGNED
Flags: needinfo?(tchevalier)
We know that only en-US has to have the new key, but we weren't sure about the process for landing a late-l10n patch. I'm fairly sure we don't have to do anything special other than have the keyword set, but I figured we should make sure.

Also, note that this might get bitrotted or otherwise conflict with bug 1022767.
Okay, got it. All we have to do is request approval for landing this on 2.1 and make sure we describe the string changes in the request message.
Flags: needinfo?(tchevalier)
Hi,

Yes, for now you only have to uplift to 2.1, we are just in "soft string freeze" for two weeks, in two weeks we won't be able to add new strings for 2.1 anymore.

Please ignore ar/fr/tw.properties files, those are not used and will be removed soon (Bug 1011519), you only have to add strings to en-US.properties.

I don't think there will be conflicts, all we need to do is adding "info-missed=Missed" in https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/locales/dialer.en-US.properties

And updating:
https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/call_info.js#L77 duration.setAttribute('data-l10n-id', 'info-missed');

And the tests as well.
Attached file PR for 1061463
Attachment #8483464 - Flags: review?(anthony)
Attachment #8483464 - Flags: review?(anthony) → review+
https://github.com/mozilla-b2g/gaia/commit/18f44035c7aa573450c8d90ba6cd03d8cf1c616f
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
[Blocking Requested - why for this release]:
We can't properly localize tabs in Call log tabs AND call info panel
blocking-b2g: --- → 2.1?
Comment on attachment 8483464 [details] [review]
PR for 1061463

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 877971
[User impact] if declined: "We can't properly localize tabs in Call log tabs AND call info panel"
[Testing completed]: Unit tests and on device
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: One new string, requested by our L10n team
Attachment #8483464 - Flags: approval-gaia-v2.1?
Attachment #8483464 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
blocking-b2g: 2.1? → 2.1+
Hi Josh,
  This issue has been verified successfully on Flame 2.1
See video: "verify_1061463.MP4".

Flame2.1 build:
Gaia-Rev        afdfa629be209dd53a1b7b6d6c95eab7077ffcd9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc3018cbdbe6
Build-ID        20141123001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141123.035029
FW-Date         Sun Nov 23 03:50:40 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(jocheng)
Flags: needinfo?(jocheng) → needinfo?(fan.luo)
Please ignore comment 10&comment 11
Flags: needinfo?(fan.luo)
Hi Theo,
After we switch to French, this issue still exists, for  the string "Missed"  in Call information screen is singular, while that in tabs of the main call log view (All | Missed).
Does that mean this issue is not fixed on the latest Flame2.1/2.2?
Please see the detial information on attachment.
Flags: needinfo?(theo.chevalier11)
(In reply to SandKing from comment #13)
> Created attachment 8552897 [details]
> Verify video:  Verified.mp4
> 
> Hi Theo,
> After we switch to French, this issue still exists, for  the string "Missed"
> in Call information screen is singular, while that in tabs of the main call
> log view (All | Missed).
> Does that mean this issue is not fixed on the latest Flame2.1/2.2?
> Please see the detial information on attachment.

The video you attached is showing that it IS fixed: we are now using a plural (Manqués) in the call log tabs while we're using a singular in Call information (Manqué). We couldn't do that before, that was the bug described in c#0
Status: RESOLVED → VERIFIED
Flags: needinfo?(theo.chevalier11)
According Comment14, change the Tracking Flags
You need to log in before you can comment on or make changes to this bug.