Closed Bug 10618 Opened 20 years ago Closed 19 years ago

[LAYER] Problem with JS image mouseovers using layers.

Categories

(Tech Evangelism Graveyard :: English US, defect, P5, trivial)

defect

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: ayresp, Assigned: bc)

References

()

Details

(Whiteboard: [PROPRIETARY-DOM])

HI! its me again! :)
if you visit http://ayresp.hypermart.net/mozilla - you will see 3 buttons and a
img in the left of the screen. IF you pass the mouse Over (onMouseOver) some
button, it change the img. The bug is, if you pass the mouse in none buttons in
the right of the screen, the JS engine consider it as a button, and change the
image.

X-man
Does this work in 4.x?  It's not at all clear what is supposed to be happening.
x-man,

please append comments to the bug report so that information does not get lost.
thanks.

X-Man says:
>  Does this work in 4.x?  It's not at all clear what is supposed to be
happening.

In netscape 4.x (i use 4.61), it doesnt work too. In netscape 4.5 the bug is
more powerfull: he doesnt understend the layers position (because of the image)
- mozilla fixed this bug and netscape 4.x doest change the img - just the last
button (if you pass the mouse over de first button, it changes the last button)
- fixed in mozilla in mozilla (milestone 8), the JS enginer and HTML enginer
work very good. you see in this HP a X image and 3 buttons (the
arein portuguese - sorry :). If you pass the mouse over a button it changes the
img, if you pass the mouse over another
img its changes another img and etc. The problem is, if you pass the mouse in
any img (top=50 left=250 - example) the
img changes. But if you pass the mouse over in top=50 left=0 the img doesnt
change - its corect. this bug happens only
in the right of the screen

did you understend?
Assignee: mccabe → joki
Component: Javascript Engine → Event Handling
QA Contact: cbegle → janc
event handler thing
Depends on: 11009, 12232
Summary: Not fixed in milstone 8 → Problem with JS image mouseovers using layers.
I think this probably shows two bugs: bug 11009 (mouseovers) and bug 12232
(events and visibility=hidden).  Marking as dependencies.  I'm not entirely
sure, though.
So the decision for 5.0 is that we're not doing layers this time around.  That 
includes the fact that we've removed even the primitive layers support 
we had in previous milestone builds (substituting DIV's for layers).  And as 
inline content, this won't work.  For one thing, none of the 'layers' can be 
accessed as properties of the document anymore.  Not sure if there are other 
problems too.

If you rewrite this without layers and still have problems send it back to me.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Summary: Problem with JS image mouseovers using layers. → [LAYER] Problem with JS image mouseovers using layers.
Keywords: verifyme
Verified
Status: RESOLVED → VERIFIED
Keywords: verifyme
Moving all [LAYER] bugs to Evangelism component for tracking and open-source
evangelism by mozilla community members of sites that need to upgrade to support 
web standards such as HTML 4.0 (instead of LAYER/ILAYER) and the W3C DOM
(instead of Nav4 document.layers[] or IE document.all()). Sites should be
lobbied to do the upgrade using the email templates that are linked to from
http://www.mozilla.org/newlayout/bugathon.html#layerbugs . When a site's owner
has confirmed receipt of the message requesting an upgrade, the bug should be
marked with the keyword evangelized to indicate that evangelism for that bug is
complete. When the site finishes the upgrade and supports standards, the bug
should be closed.
Assignee: joki → nobody
Status: VERIFIED → NEW
Component: Event Handling → Evangelism
Keywords: evangwanted
QA Contact: janc → nobody
Closing all Evangelism bugs where no evangelism is needed because page has been 
fixed, site is internal to Netscape, report is a DUP, or bug report is no longer 
appropriate for evangelism for any other reason.
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
QA Contact: nobody → zach
SPAM:Changing QA contact on 111 evang bugs as I am now the new QA contact for 
this component.

Sorry about the spam

zach
Reassigning Evangelism bugs to me, the component's new owner.  I would like to 
take this opportunity to thank nobody@mozilla.org for all of his dedication, 
contributions, and hard work, and wish him luck at his new job.  Thanks, nobody.
Assignee: nobody → BlakeR1234
Status: RESOLVED → NEW
workaround bugzilla problem that caused a bunch of evangelism bugs to be 
NEW/INVALID, NEW/FIXED, NEW/WORKSFORME or NEW/DUPLICATE
Resolution: INVALID → ---
Severity: normal → major
Status: NEW → ASSIGNED
OS: other → All
Priority: P3 → P2
Hardware: PC → All
Target Milestone: --- → mozilla0.6
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Status: ASSIGNED → NEW
Keywords: evangwanted
Target Milestone: mozilla0.6 → Future
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
This needs no evang
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → WORKSFORME
This page uses proprietary Navigator 4.x layer dom. References absolute
positioned divs using document.id where is is the id for the absolutely
positioned div. You can see the error messages in the javascript console. 
Marking priority down though.
Severity: major → trivial
Status: RESOLVED → REOPENED
Priority: P2 → P5
Resolution: WORKSFORME → ---
Whiteboard: [PROPRIETARY-DOM]
This site uses proprietary navigator 4 dom. The reporter can visit
http://www.mozilla.org/docs/web-developer/ or
http://developer.netscape.com/evangelism/ to see technigues for supporting
Mozilla in a standards based fashion.

marking won't fix.
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → WONTFIX
Verified. This page was designed as a testpage only.
Status: RESOLVED → VERIFIED
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Target Milestone: Future → ---
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.