Closed Bug 1061873 Opened 7 years ago Closed 7 years ago

some nsIXULAppInfo properties not available in child process (e10s)

Categories

(Toolkit :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1067229
Tracking Status
e10s + ---

People

(Reporter: zombie, Unassigned)

References

Details

appInfo.ID is used in lots of places, both in the addon SDK, and in some JSMs used by the SDK code, so if this is easy to fix (which i assume, based on other appInfo properties being available), it would save us some pain..
Blocks: 1046053
tracking-e10s: --- → ?
Summary: nsIXULAppInfo.ID not available in child process (e10s) → some nsIXULAppInfo properties not available in child process (e10s)
I'd nom for m-2
Blocks: e10s-shims
This is just a dup of bug 1067229 unless there's any non-ID properties in question.
well, the bug 1046053 mentions appInfo.vendor in the exception stack, so bug 1067229 should either fix all properties, or this one should stay for that..
Sorry, I didn't find this bug when I opened bug 1067229.  I updated bug 1067229 to handle the vendor too, so closing this as a dupe.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1067229
You need to log in before you can comment on or make changes to this bug.