Closed Bug 1061976 Opened 5 years ago Closed 5 years ago

Follow-ups for uniform stretch overscroll effect

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla35
Tracking Status
firefox33 --- unaffected
firefox34 --- verified
firefox35 --- fixed
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- fixed

People

(Reporter: botond, Assigned: botond)

References

Details

Attachments

(2 files)

As mentioned in bug 1057578 comments 30 and 35, we should follow-up this work with the following minor fixes:

  - Remove the code for drawing a solid-color background behind
    overscrolled layers. Since the new effect does not expose
    any blank areas in the composited region, this code is no
    longer necessary.

  - Reinstate the overscrolling tests that were removed when
    the original overscroll effect was disabled.
Note that I didn't remove FrameMetrics::mBackgroundColor or the code that sets it, as it's now also used by the low-res tiling code [1].

[1] http://mxr.mozilla.org/mozilla-central/source/gfx/layers/composite/TiledContentHost.cpp?rev=01df38521c54#372
Attachment #8483168 - Flags: review?(bgirard)
This restores the tests that were removed in bug 1055361; for this, I'm basically just looking for a rubber-stamp.
Attachment #8483169 - Flags: review?(bgirard)
Attachment #8483168 - Flags: review?(bgirard) → review+
Attachment #8483169 - Flags: review?(bgirard) → review+
https://hg.mozilla.org/mozilla-central/rev/6a723264bc90
https://hg.mozilla.org/mozilla-central/rev/a412d9988671
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Botond, please request uplift for (at least) part 1, as it fixes bug 1077490.
Comment on attachment 8483168 [details] [diff] [review]
Part 1 - Remove overscroll background drawing code

Approval Request Comment
[Feature/regressing bug #]:
  Bug 1014280 (drawing background in overscrolled state).

  This feature is obsoleted by bug 1057578, which changed the
  overscroll effect to not expose regions behind the overscrolled
  layer.

  This patch removes the obsoleted feature.

[User impact if declined]:
  Sometimes, a background is incorrectly drawn behind a
  transparent portion of a layer.

[Describe test coverage new/current, TBPL]:
  On m-c since 2014-09-04 with no regressions.

[Risks and why]: 
  Low. Not drawing a background color can potentially unmask
  bugs in other code like bug 1065008 (which was a bug in 
  compositor culling). However, the fact that we haven't come
  across such bugs (other than bug 1065008) in the month
  this has been on m-c is encouraging.

[String/UUID change made/needed]:
  None
Attachment #8483168 - Flags: approval-mozilla-aurora?
Comment on attachment 8483168 [details] [diff] [review]
Part 1 - Remove overscroll background drawing code

Approving to bugs/regressions like https://bugzilla.mozilla.org/show_bug.cgi?id=1077490 and since its low risk. :johan, can you please help verify the DUP you filed once this lands ? Thanks!
Attachment #8483168 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(jlorenzo)
Great! The contact's picture doesn't disappear anymore when you overscroll after this patch (like in bug 1077490). Verified on: 
Gaia-Rev        778ebac47554e1c4b7e9a952d73e850f58123914
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/c4a4b04c617c
Build-ID        20141006000205
Version         34.0a2
Device-Name     flame-kk
FW-Release      4.4.2
FW-Incremental  34
FW-Date         Tue Sep 30 14:06:36 CST 2014
Bootloader      L1TC00011840
Status: RESOLVED → VERIFIED
Flags: needinfo?(jlorenzo)
You need to log in before you can comment on or make changes to this bug.