Closed Bug 1061990 Opened 6 years ago Closed 6 years ago

Cache size does not update after clearing cache

Categories

(SeaMonkey :: Preferences, defect)

defect
Not set
normal

Tracking

(seamonkey2.29 affected, seamonkey2.30 affected, seamonkey2.31 fixed, seamonkey2.32 fixed, seamonkey2.33 fixed)

RESOLVED FIXED
seamonkey2.33
Tracking Status
seamonkey2.29 --- affected
seamonkey2.30 --- affected
seamonkey2.31 --- fixed
seamonkey2.32 --- fixed
seamonkey2.33 --- fixed

People

(Reporter: neil, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(2 files)

Also an error is thrown to the Error Console.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8483117 - Flags: review?(bugzilla)
Comment on attachment 8483117 [details] [diff] [review]
Restore updateActualCacheSize

Sorry for the delay...
Attachment #8483117 - Flags: review?(bugzilla) → review+
Comment on attachment 8483117 [details] [diff] [review]
Restore updateActualCacheSize

[Approval Request Comment]
Regression caused by (bug #): 999462
User impact if declined: Clear cache button appears to fail
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #8483117 - Flags: approval-comm-beta?
Attachment #8483117 - Flags: approval-comm-aurora?
Attachment #8483117 - Flags: approval-comm-beta?
Attachment #8483117 - Flags: approval-comm-beta+
Attachment #8483117 - Flags: approval-comm-aurora?
Attachment #8483117 - Flags: approval-comm-aurora+
Oops, I forgot to update the flags when I checked this in.
Target Milestone: --- → seamonkey2.33
Duplicate of this bug: 1084020
(In reply to comment #6)
> Oops, I forgot to update the flags when I checked this in.

And I still forgot to resolve the bug. Sigh...
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Bug is still present in SeaMonkey 2.32.
Ah, the new problem is that the cache clears asynchronously, so it hasn't been cleared when we try to update the cache size. If you wait a couple of seconds and then click Clear Cache again it will then update correctly.
Can it be changed to update synchronously as it was before?
You need to log in before you can comment on or make changes to this bug.