when being on call ,Music on playing and with earphone.

RESOLVED DUPLICATE of bug 927862

Status

Firefox OS
AudioChannel
--
major
RESOLVED DUPLICATE of bug 927862
3 years ago
3 years ago

People

(Reporter: soyeon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [LibGLA,TD94239,QE1, A])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; Tablet PC 2.0; CNS_UA; AD_LOGON=4C47452E4E4554)

Steps to reproduce:

gecko :4ed0fd687be1220b34b82ec44076c0d65ff931a8 

Steps to Reproduce
  1. Launch Music app
  2. Play any music with earphone
  3. Give a incoming phone call
  4. after call accepted, music is played for 1-2 seconds.




Actual results:

Actual Results
music have 2 seconds on earphone



Reproduction Frequency: 
100%


Expected results:

Expected Results
music will pause after call accepted
(Reporter)

Updated

3 years ago
Whiteboard: [LibGLA,TD94239,QE1, A]
(Reporter)

Updated

3 years ago
Component: General → AudioChannel
Product: Core → Firefox OS
Version: 2.0 Branch → unspecified
(Reporter)

Updated

3 years ago
Severity: normal → major
(Reporter)

Comment 1

3 years ago
it is similar issue Bug 1020263
(Reporter)

Updated

3 years ago
Flags: needinfo?(scheng)

Comment 2

3 years ago
(In reply to soyeon from comment #1)
> it is similar issue Bug 1020263

Note: the two are different, they are already accepting call / playing ringtones.
(Reporter)

Comment 3

3 years ago
sorry. I want to modify that.
when call accepted, ringtone sound is played for 1-2 seconds.
I wrote that music sound is played before.

But,as testing many times, I knew the fact. 

I'm sorry to reverse the content.
Flags: needinfo?(scheng)
Hi Thomas -

Could you help to find someone to check this issue?

Thanks

Vance
Flags: needinfo?(ttsai)

Comment 5

3 years ago
star and alive, can you also comment? Thanks!
Flags: needinfo?(ttsai)
Flags: needinfo?(scheng)
Flags: needinfo?(alive)

Comment 6

3 years ago
(In reply to thomas tsai from comment #5)
> star and alive, can you also comment? Thanks!


Hi, Alive

Could you check whether it is attention windows issue or not? Thanks
Flags: needinfo?(scheng)
1. Which branch?
2. What do you mean by accepting call? Press accept *right away* ? Does it still happen if you accept the call after 3sec? Does it still happen if you don't accept the call but put the phone ringing?

If this is v2.0 or v1.4 and answer to Q2 is right away(means accept doesn't matter - it also happens if not accepted but ringing), it's already fixed in master by bug 927862.
Flags: needinfo?(alive)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #7)
> 1. Which branch?
> 2. What do you mean by accepting call? Press accept *right away* ? Does it
> still happen if you accept the call after 3sec? Does it still happen if you
> don't accept the call but put the phone ringing?
> 
> If this is v2.0 or v1.4 and answer to Q2 is right away(means accept doesn't
> matter - it also happens if not accepted but ringing), it's already fixed in
> master by bug 927862.

Hi Alive -

It is 2.0

And yes, this issue happens only when you pick up the phone within 3 seconds when the incoming call notification appears. "Not accept will not have this issue"

So does 927862 solved the above scenario as well? If so, could you help to land it on 2.0 as well since partner is asking for the fix?

Thanks for your help
Flags: needinfo?(alive)
(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #8)
> (In reply to Alive Kuo [:alive][NEEDINFO!] from comment #7)
> > 1. Which branch?
> > 2. What do you mean by accepting call? Press accept *right away* ? Does it
> > still happen if you accept the call after 3sec? Does it still happen if you
> > don't accept the call but put the phone ringing?
> > 
> > If this is v2.0 or v1.4 and answer to Q2 is right away(means accept doesn't
> > matter - it also happens if not accepted but ringing), it's already fixed in
> > master by bug 927862.
> 
> Hi Alive -
> 
> It is 2.0
> 
> And yes, this issue happens only when you pick up the phone within 3 seconds
> when the incoming call notification appears. "Not accept will not have this
> issue"
> 
> So does 927862 solved the above scenario as well? If so, could you help to
> land it on 2.0 as well since partner is asking for the fix?
> 
> Thanks for your help

Sorry, bug 927862 is a tremendous change to the code base, so I cannot land it to v2.0.
Please test v2.1/master again to confirm this issue is fixed in master/v2.1 and mark this as dupe of bug 927862 and argue there.
Flags: needinfo?(alive)
Confirmed fixed in master/2.1

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 927862

Comment 11

3 years ago
Is it available to affect v2.0 with bug 927862 ?
You need to log in before you can comment on or make changes to this bug.