No confirm window pops up to inform users that deleted numbers are removed from an ICE contact.

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: oteo, Assigned: jmcf)

Tracking

({late-l10n})

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
late-l10n
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.1 affected, b2g-v2.2 verified)

Details

(Whiteboard: [p=1] [2.1-flame-test-run-2])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
According to the ICE spec (https://bug1026682.bugzilla.mozilla.org/attachment.cgi?id=8459474 on page 15) when number/s is/are deleted from an ICE contact, user should be informed with a confirm window pop-up.

Flame
2.1
Gecko-6be7031
Gaia-e1f6d88

Pre-requisites:
1. ICE Contact saved

Steps to reproduce:
1.Go to contacts app and select an ICE contact from the list
2.Tap to edit contact
3.Remove a number or several numbers from the Contact

Expected results:
A confirm window should inform to the user that the deleted number are removed from the ICE list as well

Actual results:
no Confirm window implemented
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]: It's really important for the user be aware that deleting those numbers can make impossible to call to those preferred contacts in case of emergency
Blocks: 1026682
blocking-b2g: --- → 2.1?
triage: major issue to new feature
blocking-b2g: 2.1? → 2.1+
Carrie, what should we say if we remove all the phones for a contact? Same wording?
Flags: needinfo?(cawang)
Hi, 


If the ICE contact has more than one number and we only delete one of them, we show the strings on p.15 Screen 3 and the contact will not be removed from ICE list.

If all the numbers of the ICE contact are deleted the contact will be removed from ICE contacts and we show the strings as below,

----------------------------------------------
All the numbers are deleted. This contact is 
removed from the ICE Contacts.

I'll add this case to the spec to keep it updated.

Thanks!
Flags: needinfo?(cawang)
Duplicate of this bug: 1061420
(Assignee)

Updated

4 years ago
Assignee: nobody → jmcf
Triage group discussed and this doesn't meet the blocking criteria for stopping a whole release. Please review the criteria at https://wiki.mozilla.org/B2G/Triage#Blocker_Triage_Guidelines.

This is a new feature, and the lack of this confirmation prompt doesn't prevent the use of the feature. If this is fixed in 2.1 timeframe, ask for approval and land! Otherwise, it seems like it can ship in the next version.

Wesley and Maria, if there's some reason this should actually stop the release from shipping, please discuss!
blocking-b2g: 2.1+ → 2.1?
blocking-b2g: 2.1? → backlog
This will have an easy fix and the improve to the user experience will be significant, so let's fix this and ask for approval
(Assignee)

Comment 8

4 years ago
Created attachment 8488563 [details]
24000.html

Francisco,

Please could you do a quick review? Then, I can polish it up and create a test
Attachment #8488563 - Flags: feedback?(francisco)
Comment on attachment 8488563 [details]
24000.html

Definitely looking pretty good
Attachment #8488563 - Flags: feedback?(francisco) → feedback+
(Assignee)

Updated

4 years ago
Blocks: 1067234
(Assignee)

Comment 10

4 years ago
Comment on attachment 8488563 [details]
24000.html

Francisco,

I believe this is ready to be reviewed. There are no tests in the PR because we are going to create an integration test for this (bug 1067234).
Attachment #8488563 - Flags: review?(francisco)
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2.1 S5 (26sep)
Whiteboard: [p=1]
Comment on attachment 8488563 [details]
24000.html

We are not removing from ICE the contact if we remove all the phone numbers, we are just displaying the message (which looks good).
Attachment #8488563 - Flags: review?(francisco) → review-
(Assignee)

Comment 12

4 years ago
Francisco,

The purpose of the bug is to show the alert to the user but not to actually remove the ICE contact. That should be another bug, and I believed you were implementing that. 

If that is not the case I can open a new one and solve it.

thanks
Flags: needinfo?(francisco)
(Assignee)

Updated

4 years ago
Attachment #8488563 - Flags: review- → review?(francisco)
(In reply to Jose Manuel Cantera from comment #12)
> Francisco,
> 
> The purpose of the bug is to show the alert to the user but not to actually
> remove the ICE contact. That should be another bug, and I believed you were
> implementing that. 
> 
> If that is not the case I can open a new one and solve it.
> 
> thanks

The previous work done was about delete contacts (full contacts), and removing the ICE group. If we perform a check about removing just the phone, if we remove all the phones, we should remove that contact from the ICE group as well.
Flags: needinfo?(francisco)
Sorry, when I mean the ice group, I mean removing them as ICE contact.

Then the group will dissapear if it was the only ICE contact.
(Assignee)

Comment 15

4 years ago
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #14)
> Sorry, when I mean the ice group, I mean removing them as ICE contact.
> 
> Then the group will dissapear if it was the only ICE contact.

Yes, but that should be solved in another bug. Can we land this and then open a new bug for that functionality?
Fair enough, we do have bug 1061420 to actually perform that last bit.

Please, go ahead and merge once everything is green.
Attachment #8488563 - Flags: review?(francisco) → review+

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [p=1] → [p=1] [2.1-flame-test-run-2]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Comment 17

4 years ago
landed in master:

https://github.com/mozilla-b2g/gaia/commit/0d11eae32af28284ab9c4520d45af4e12dcd624f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Keywords: verifyme
Whiteboard: [p=1] [2.1-flame-test-run-2] → [p=1] [2.1-flame-test-run-2]
Comment on attachment 8488563 [details]
24000.html

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Ice contacts feature
[User impact] if declined:
User won't know that could be delete information that later could be use in case of an emergency
[Testing completed]:
Smoke test passed on flame
[Risk to taking this patch] (and alternatives if risky):
Pretty low risk
[String changes made]:
ICEContactDelTel
ICEContactDelTelAll
Attachment #8488563 - Flags: approval-gaia-v2.1?(bbajaj)
Keywords: late-l10n
Tested and *not* working, because if i set an ICE contact with 3 phones numbers only I can see warning when I delete only first phone number. If i delete a phone number, I can see warning, but if i close contact application and after i open app and delete other phone number to ICE contact I can't see warning.

Flame
2.2
Gecko: cce3dff
Gaia: 897bd62
(In reply to Loli (:lolimartinezcr) from comment #19)
> Tested and *not* working, because if i set an ICE contact with 3 phones
> numbers only I can see warning when I delete only first phone number. If i
> delete a phone number, I can see warning, but if i close contact application
> and after i open app and delete other phone number to ICE contact I can't
> see warning.
> 
> Flame
> 2.2
> Gecko: cce3dff
> Gaia: 897bd62

Sorry but I have confused because when i tap in "X" button in phone number doesn't appear warning, it only appears when user presses "update" button.

Tested and working
 Flame
 2.2
 Gecko: cce3dff
 Gaia: 897bd62
Comment on attachment 8488563 [details]
24000.html

Too late for new strings.
Attachment #8488563 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1-
(Reporter)

Updated

4 years ago
status-b2g-v2.2: affected → fixed
Created attachment 8499434 [details]
[2.1 Contacts] Support for ICE Contacts v0.3.pdf

Update the spec as a reference. Thanks!
Issue is verified fixed in Flame 2.2 build (Full Flash, nightly). 

Actual Results: Assigning an ICE contact (Person A), then deleting their number(s) prompts the notification "Deleted phone numbers are removed from ICE Contact". 

Device: Flame Master
Build ID: 20141015040201
Gaia: 5f1f0960ae9d22acf2a324ad37a48174d6df87f6
Gecko: 62f0b771583c
Version: 36.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1081696
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.