bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

[Contacts] Delete all numbers which belong to an ICE contact, that ICE should be removed from ICE list

VERIFIED FIXED in Firefox OS v2.1


Firefox OS
4 years ago
3 years ago


(Reporter: ericcc, Assigned: Jose Manuel Cantera)


2.1 S5 (26sep)
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)


(Whiteboard: [p=3][2.1-flame-test-run-2])


(2 attachments)



4 years ago
### STR
1. Set ICE to some contact A(with number), make sure it appears on top of contact list.
2. Remove all phone numbers of contact A, but still keep A in contact.

### Actual 
ICE list still has the contact A.

### Expected
Contact A should be removed from ICE list.
Graph 5, Page 15 of https://bugzilla.mozilla.org/attachment.cgi?id=8459474

### Version
Gaia      e7d31f0e9b6b19d9b484eeec8fb980718bc40d79
Gecko     https://hg.mozilla.org/mozilla-central/rev/532b5fb77ba1
BuildID   20140901160203
Version   34.0a1
ro.build.date=Fri Jun 27 15:57:58 CST 2014


4 years ago
Blocks: 1026682

Comment 1

4 years ago
[Blocking Requested - why for this release]: Spec
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=Gaia::Contacts]
Assignee: nobody → francisco
Whiteboard: [p=3]
triage: align to spec of essential feature
blocking-b2g: 2.1? → 2.1+
This is a case of bug 1062595
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1062595


4 years ago
Resolution: DUPLICATE → ---


4 years ago
Assignee: francisco → jmcf

Comment 4

4 years ago
Created attachment 8490631 [details]
Attachment #8490631 - Flags: review?(francisco)
Comment on attachment 8490631 [details]

Working perfect and minimun impact in code. Awesome!
Attachment #8490631 - Flags: review?(francisco) → review+

Comment 6

4 years ago
landed in master:

Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
status-b2g-v2.2: --- → affected
Target Milestone: --- → 2.1 S5 (26sep)
Comment on attachment 8490631 [details]

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Ice contacts feature
[User impact] if declined:
Wrong information displayed on to the user from a feature dedicated to security.
[Testing completed]:
Smoke test passed on flame
[Risk to taking this patch] (and alternatives if risky):
Pretty low, patch is just 2 lines of code executing the action of removing a conatct without numbers
[String changes made]:

It requires bug 1062595 to be uplifted first. That one also has been asked for approval-gaia-v2.1
Attachment #8490631 - Flags: approval-gaia-v2.1?(bbajaj)
status-b2g-v2.2: affected → fixed
QA Whiteboard: [COM=Gaia::Contacts] → [COM=Gaia::Contacts][QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [p=3] → [p=3][2.1-flame-test-run-2]
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #7)
> It requires bug 1062595 to be uplifted first. That one also has been asked
> for approval-gaia-v2.1

Unfortunately bug 1062595 has really-too-late-l10n. What is it blocking this one? It's not obvious from reading this patche's code.

Comment 9

4 years ago
It is feasible to provide a patch for this functionality that does not depend on the L10N one.

Francisco, what do you think?
Flags: needinfo?(dharris) → needinfo?(francisco)
I think we will need Carrie input here to decide, IMHO, a message is necessary.

Carrie what do you think about Jose's proposal?
Flags: needinfo?(francisco) → needinfo?(cawang)
Attachment #8490631 - Flags: approval-gaia-v2.1?(bbajaj)
Yes, I think the message would be very important. Agree with you guys on this one. Thanks!
Flags: needinfo?(cawang)
Duplicate of this bug: 1071632
Please request approval to uplift to 2.1.
This is major issue on new feature ICE contact.
Flags: needinfo?(jmcf)

Comment 14

4 years ago
(In reply to Wesley Huang [:wesley_huang] from comment #13)
> Please request approval to uplift to 2.1.
> This is major issue on new feature ICE contact.


I totally agree with you but unfortunately this bug depends on bug 1062595 which was not approved for uplifting due to L10N issues.

Please let us know on next steps

Flags: needinfo?(jmcf) → needinfo?(whuang)
QA Whiteboard: [COM=Gaia::Contacts][QAnalyst-Triage?] → [COM=Gaia::Contacts][QAnalyst-Triage+]
Hi Jose.

Comment 9 seems to be the best approach we can take for 2.1.
I spoke with Carrie and she had no objection since bug 1062595 as late l10n couldn't uplift.

(here I also ni? Carrie in case she has more to input)
Flags: needinfo?(whuang)
Flags: needinfo?(jmcf)
Flags: needinfo?(cawang)

Comment 16

4 years ago
Created attachment 8498178 [details]

patch for v2.1 as per request from Wesley. this patch does not contain any L10n change or addition
Attachment #8498178 - Flags: review?(crdlc)
Flags: needinfo?(jmcf)
Comment on attachment 8498178 [details]

Good job thx
Attachment #8498178 - Flags: review?(crdlc) → review+


4 years ago
status-b2g-v2.1: affected → fixed


4 years ago
Keywords: verifyme
I've checked it on today's build. Looks good! Thanks!
Flags: needinfo?(cawang)

Comment 20

4 years ago
Issue fixed and verified on Flame 2.2 Master KK (319mb) (Full Flash), Flame 2.1 KK (319mb) (Full Flash)

when all numbers are removed ICE contact, Contact is removed the ICE contact list on the top of the contacts list. This works with either ICE contact slot with varying numbers and number type variations.  

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

2.1 KK (319mb) (Full Flash)

Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
Build ID: 20141010000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Version: 34.0a2 Flame 2.1 KK (319mb)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [COM=Gaia::Contacts][QAnalyst-Triage+] → [COM=Gaia::Contacts][QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [COM=Gaia::Contacts][QAnalyst-Triage?] → [COM=Gaia::Contacts][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1139812
You need to log in before you can comment on or make changes to this bug.