Closed Bug 1062835 Opened 7 years ago Closed 7 years ago

Missing text on the start call page for non-English locales

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
normal

Tracking

(firefox34 verified, firefox35 verified)

VERIFIED FIXED
mozilla35
Tracking Status
firefox34 --- verified
firefox35 --- verified

People

(Reporter: pauly, Assigned: standard8)

References

Details

(Whiteboard: [fig:wontverify])

Attachments

(3 files)

34.0a1 (2014-09-02) AR, FA, HE
I believe this is in the standalone app (link clicker side) of the app, and I believe this is because we don't have translations for certain languages in the standalone app yet.  It shouldn't be blank though.  

Dan -- Have we filed a bug yet about the strings being blank (instead of some default language) when translations for the preferred language are not available?  I think this bug would be dup'd to that.
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #1)
> I believe this is in the standalone app (link clicker side) of the app, and
> I believe this is because we don't have translations for certain languages
> in the standalone app yet.  It shouldn't be blank though.  
> 
> Dan -- Have we filed a bug yet about the strings being blank (instead of
> some default language) when translations for the preferred language are not
> available?  I think this bug would be dup'd to that.

Meant to do a needinfo for this question ^^^
Flags: needinfo?(dmose)
No we haven't, I certainly wasn't aware of this, but its definitely all locales.

I think we want this fixed soon, as this is going to affect people's ability to test.

I'll take a look at it, as I thought it was doing this already.
Assignee: nobody → standard8
Flags: needinfo?(dmose)
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Missing text on the start call page for RTL locales → Missing text on the start call page for non-English locales
Blocks: 1000269
This transitions us to use Gaia's version of L10n.js for the standalone application.

The only real differences in the api are the ways to get the language and direction, plus the way the locale data files are loaded.

The locale data files now only support a single 'ini' file which imports the locales - you can't put the strings in the same file. That's probably fine, as it starts to set up nicely for bug 1000269. The minor downside is another round trip or two to the server, but I think we can look at optimising that later if it is a real issue.

The gaia l10n.js is unmodified, it is extracted from the revision referenced in the filename.

I dropped the fr translation, as when we do do bug 1000269, we'll need it in a different place anyway.
Attachment #8484173 - Flags: review?(nperriault)
Example addition of FR translation. Not for landing, just to show and allow easy testing.
Comment on attachment 8484173 [details] [diff] [review]
Missing text on Loop's link-clicker UI for non-English locales. Update the standalone app to the gaia version of L10n.js which supports fallback automatically.

Review of attachment 8484173 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.

::: browser/components/loop/standalone/content/js/webapp.jsx
@@ +16,5 @@
>  
>    var sharedModels = loop.shared.models,
>        sharedViews = loop.shared.views,
>        baseServerUrl = loop.config.serverUrl,
> +      __ = mozL10n.get;

Could you please take advantage you're around for getting rid of that __ helper? using l10n.get is probably as convenient, while more explicit.
Attachment #8484173 - Flags: review?(nperriault) → review+
Duplicate of this bug: 1062771
I did the __ replacement as it wasn't too big and confusing to the main patch:

https://hg.mozilla.org/integration/fx-team/rev/f550c2de2ddc
Target Milestone: --- → mozilla35
Verified fixed FF 35.0a1 (2014-09-07) AR, IT, FR.
One minor issue though on the RTL locales: http://i.imgur.com/7aMqlOc.png?1
Say if you think it's worth tracking separately.
Status: RESOLVED → VERIFIED
(In reply to Paul Silaghi, QA [:pauly] from comment #10)
> Verified fixed FF 35.0a1 (2014-09-07) AR, IT, FR.
> One minor issue though on the RTL locales: http://i.imgur.com/7aMqlOc.png?1
> Say if you think it's worth tracking separately.

iirc, that may actually be right - because the text itself is English, and not an RTL one; once you transition to an actual RTL language I think it would display in the right place.
Depends on: 1065631
Duplicate of this bug: 1059776
Flags: qe-verify+
QA Contact: anthony.s.hughes → paul.silaghi
Paul can you please test this again across platforms using the following Try-server build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/rjesup@wgate.com-f9eb2cbac352
Flags: needinfo?(paul.silaghi)
Whiteboard: [fig:verifyme]
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #13)
> Paul can you please test this again across platforms using the following
> Try-server build?
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/rjesup@wgate.com-
> f9eb2cbac352
There are no locales available
Flags: needinfo?(paul.silaghi)
Whiteboard: [fig:verifyme] → [fig:wontverify]
Comment on attachment 8484173 [details] [diff] [review]
Missing text on Loop's link-clicker UI for non-English locales. Update the standalone app to the gaia version of L10n.js which supports fallback automatically.

Approval Request Comment
Uplift request for patches staged and tested on Fig
Attachment #8484173 - Flags: approval-mozilla-aurora?
Comment on attachment 8484173 [details] [diff] [review]
Missing text on Loop's link-clicker UI for non-English locales. Update the standalone app to the gaia version of L10n.js which supports fallback automatically.

I worked with Randell and Maire on uplifting a large number of Loop bugs at once. All of the bugs have been staged on Fig and tested by QE before uplift to Aurora. As well, all of the bugs are isolated to the Loop client. Randell handled the uplift with my approval. I am adding approval to the bug after the fact for bookkeeping.
Attachment #8484173 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Paul, can you please test this in Aurora now that it's been uplifted?
Flags: needinfo?(paul.silaghi)
Verified fixed Chrome 38.0.2125.101 vs FF 34b1 AR, FR, DE Win 7 x64
Flags: needinfo?(paul.silaghi)
You need to log in before you can comment on or make changes to this bug.