3.14% Win7 tp5 regression on Aurora (v.33) August 18 from push f0bdcf487ac4

RESOLVED WONTFIX

Status

Testing
Talos
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

({perf, regression})

Trunk
x86
Windows 7
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression])

(Reporter)

Description

4 years ago
here is a graph showing the regression:
http://graphs.mozilla.org/graph.html#tests=[[255,52,25]]&sel=none&displayrange=90&datatype=running

I did some retriggers:
https://tbpl.mozilla.org/?tree=Mozilla-Aurora&fromchange=74e3bdff5561&tochange=aa20cc59dedf&jobname=Windows%207%2032-bit%20mozilla-aurora%20pgo%20talos%20tp5o

You can see where the tp5o_paint value goes above 208 (and remains there) is from this push:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=39a821f3aac9&tochange=f0bdcf487ac4

in that push there are 4 bugs, 1016434 is a backout (there is no corresponding improvement, so I don't suspect it) and the other 3 are suspect.
(Reporter)

Comment 1

4 years ago
:jandem, :jya, do you have thoughts on the patches you landed and if they would cause a 3% regression in tp5 on windows 7?
Flags: needinfo?(jyavenard)
Flags: needinfo?(jdemooij)
> in that push there are 4 bugs, 1016434 is a backout (there is no
> corresponding improvement, so I don't suspect it) and the other 3 are
> suspect.

The backed-out change (bug 759252) claimed to be good for perf, though. Jaws, would it be plausible that the initial gain got washed out in noise while the backout's regression got noticed? (Maybe combined with whatever changes happened to be riding along)
Flags: needinfo?(jaws)
my changes had nothing to do with paint. Only changed a value threshold so audio playback would start
(In reply to David Major [:dmajor] from comment #2)
> > in that push there are 4 bugs, 1016434 is a backout (there is no
> > corresponding improvement, so I don't suspect it) and the other 3 are
> > suspect.
> 
> The backed-out change (bug 759252) claimed to be good for perf, though.
> Jaws, would it be plausible that the initial gain got washed out in noise
> while the backout's regression got noticed? (Maybe combined with whatever
> changes happened to be riding along)

Yeah that sounds plausible to me.
Flags: needinfo?(jaws)
It *could* be bug 1054359 but I really doubt it. Based on comment 2 and comment 4, bug 759252 seems more likely...
Flags: needinfo?(jdemooij)
Flags: needinfo?(jyavenard)
(Reporter)

Comment 6

4 years ago
:jaws, should we reland on try to see if the backout was the cause.  This is a small regression on a single platform (although an important platform).  If you have other ideas to try out, I would be happy to do that.
Flags: needinfo?(jaws)
Sorry for the delay. As for bug 1037214, I just changed the way OOM errors are reported in a small portion of code, swapping a |NS_RUNTIMEABORT("OOM")| with error reporting to the script: I'm not touching any paint code (at least directly).
We don't have any plans to reland until OMTA is ready. Given that we just had a patch land and then back out, this seems pretty clear to me.
Flags: needinfo?(jaws)
(Reporter)

Comment 9

4 years ago
as this is a shipped and small regression, I am going to close this. feel free to reopen if you feel strongly we should keep this open.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.