Version 31 does not respond to HTML 5 audio - Please visit www.mapetiteradio.com - audio stream does not work anymore - was working perfectly in version 30

RESOLVED FIXED in Firefox 32, Firefox OS v2.0

Status

()

Core
Audio/Video
--
blocker
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Alain Gariépy, Assigned: jya)

Tracking

({dev-doc-needed, regression, site-compat})

31 Branch
mozilla34
x86_64
Windows 8.1
dev-doc-needed, regression, site-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox31 wontfix, firefox32+ verified, firefox33+ verified, firefox34 fixed, firefox-esr24 unaffected, firefox-esr31 wontfix, b2g-v1.4 unaffected, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Version 31 does not respond to HTML 5 audio - Please visit www.mapetiteradio.com - audio streams does not work anymore - was working perfectly in version 30.

All others navigarors works fine with our website.
Component: Build Config → Untriaged
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, regressionwindow-wanted

Comment 1

4 years ago
[Tracking Requested - why for this release]: Regressed by Bug 984698 

Regression window
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8510052b2313
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140320152510
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e076f1fb825b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140320154837
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8510052b2313&tochange=e076f1fb825b

Regressed by:
e076f1fb825b	Chris Pearce — Bug 984698 - Reduce the amount of audio prerolled when we are not also decoding video in the same file. r=padenot
Blocks: 984698
status-firefox31: --- → affected
status-firefox32: --- → affected
status-firefox33: --- → affected
status-firefox34: --- → affected
status-firefox-esr24: --- → unaffected
tracking-firefox32: --- → ?
tracking-firefox33: --- → ?
tracking-firefox34: --- → ?
Component: Untriaged → Video/Audio
Keywords: regressionwindow-wanted
Product: Firefox → Core

Comment 2

4 years ago
[Tracking Requested - why for this release]:
status-firefox-esr31: --- → affected
tracking-firefox-esr31: --- → ?
status-firefox31: affected → wontfix
tracking-firefox32: ? → +
tracking-firefox33: ? → +
tracking-firefox34: ? → ---
tracking-firefox-esr31: ? → +
Created attachment 8471126 [details]
simplified test case

The simplified test case doesn't auto play
(Assignee)

Updated

4 years ago
Assignee: nobody → jyavenard
(Assignee)

Comment 4

4 years ago
(In reply to Alice0775 White from comment #1)
> Regressed by:
> e076f1fb825b	Chris Pearce — Bug 984698 - Reduce the amount of audio
> prerolled when we are not also decoding video in the same file. r=padenot

there is no way this commit has any effect on autostart with audio-only stream

Comment 5

4 years ago
(In reply to Jean-Yves Avenard [:jya] from comment #4)
> (In reply to Alice0775 White from comment #1)
> > Regressed by:
> > e076f1fb825b	Chris Pearce — Bug 984698 - Reduce the amount of audio
> > prerolled when we are not also decoding video in the same file. r=padenot
> 
> there is no way this commit has any effect on autostart with audio-only
> stream


Download win32 build and load the attached simplified test case.

Last Good build
http://inbound-archive.pub.build.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1395354310/
Bad build
http://inbound-archive.pub.build.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1395355717/

You can easily check that rebgrssion range is CORRECT.
(these archived build will be deleted within 25 days)
(In reply to Jean-Yves Avenard [:jya] from comment #4)
> (In reply to Alice0775 White from comment #1)
> > Regressed by:
> > e076f1fb825b	Chris Pearce — Bug 984698 - Reduce the amount of audio
> > prerolled when we are not also decoding video in the same file. r=padenot
> 
> there is no way this commit has any effect on autostart with audio-only
> stream

Look at MediaDecoderStateMachine::HasFutureAudio().
(Assignee)

Comment 7

4 years ago
Created attachment 8474406 [details] [diff] [review]
Fix media element's autoplay for audio-only stream

fix autoplay for audio only stream
Attachment #8474406 - Flags: review?(cpearce)
Comment on attachment 8474406 [details] [diff] [review]
Fix media element's autoplay for audio-only stream

Review of attachment 8474406 [details] [diff] [review]:
-----------------------------------------------------------------

OMG lol sux.
Attachment #8474406 - Flags: review?(cpearce) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Jean-Yves, can we get an uplift request for aurora & beta? Thanks
Flags: needinfo?(jyavenard)
(Assignee)

Comment 12

4 years ago
Comment on attachment 8474406 [details] [diff] [review]
Fix media element's autoplay for audio-only stream

Approval Request Comment
[Feature/regressing bug #]:984698 . Bug is only triggered more often following 984698
[User impact if declined]:Audio playback not starting. Site's owner recommendation being to use IE/Chrome
[Describe test coverage new/current, TBPL]: on m-c
[Risks and why]: Can't think of any
[String/UUID change made/needed]: none
Attachment #8474406 - Flags: approval-mozilla-aurora?
Flags: needinfo?(jyavenard)
Attachment #8474406 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Jean-Yves Avenard [:jya] from comment #12)
> Comment on attachment 8474406 [details] [diff] [review]
> Fix media element's autoplay for audio-only stream
> 
> Approval Request Comment
> [Feature/regressing bug #]:984698 . Bug is only triggered more often
> following 984698
> [User impact if declined]:Audio playback not starting. Site's owner
> recommendation being to use IE/Chrome
> [Describe test coverage new/current, TBPL]: on m-c
> [Risks and why]: Can't think of any
> [String/UUID change made/needed]: none

This looks safe enough. Is there any reason not to take this on beta? If not, let's get this in today for beta8.
Flags: needinfo?(jyavenard)
(Assignee)

Comment 14

4 years ago
I only requested approval-mozilla-aurora, following instructions there:
https://wiki.mozilla.org/Release_Management/Uplift_rules#Aurora_Uplift_.28approval-mozilla-aurora.29

"Must be landed on mozilla-central as well as mozilla-aurora"

can certainly do beta too
(Assignee)

Comment 15

4 years ago
Comment on attachment 8474406 [details] [diff] [review]
Fix media element's autoplay for audio-only stream

Approval Request Comment
[Feature/regressing bug #]:984698 . Bug is only triggered more often following 984698
[User impact if declined]:Audio playback not starting. Site's owner recommendation being to use IE/Chrome
[Describe test coverage new/current, TBPL]: on m-c
[Risks and why]: Can't think of any
[String/UUID change made/needed]: none
Attachment #8474406 - Flags: approval-mozilla-beta?
Flags: needinfo?(jyavenard)
Comment on attachment 8474406 [details] [diff] [review]
Fix media element's autoplay for audio-only stream

I'm approving this small patch for beta before landing on m-c in order to make beta8.

For future, it is fine to request aurora and beta uplift at the same time.
Attachment #8474406 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-aurora/rev/392aca6fddc2
https://hg.mozilla.org/releases/mozilla-beta/rev/f595bdcdbd1e
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
status-firefox32: affected → fixed
status-firefox33: affected → fixed
status-firefox34: affected → fixed
https://hg.mozilla.org/mozilla-central/rev/7cfde660c0e8
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Keywords: verifyme
Verified as fixed using the following environment:

FF32.0b8
Build Id: 20140818191513
OS: Win 7 x64, Mac Os X 10.10, Ubuntu 14.04 x64
status-firefox32: fixed → verified
Depends on: 1059456

Updated

4 years ago
Keywords: dev-doc-needed, site-compat
Depends on: 1062857
(Reporter)

Comment 21

4 years ago
Hi to all of you,

Thanks, the bugs with HTML 5 audio stream seems to be resolved and fixed in version 33 Beta. It seems very stable.

Version 32, still crash after a while when zapping radio stations.

Please check : http://mapetiteradio.com

Note : all other navigators were and still handle properly our system. So we made no changes to our code.
Thank you Alain! I'm marking this as Verified on Firefox 33 based on the previous comment.
status-firefox33: fixed → verified
Keywords: verifyme
(Reporter)

Comment 23

4 years ago
Hi again,

I was too much enthusiast. It did crashed again in version 33 Beta. Autoplay works, but when zapping radio stations, it crash.

Sorry.

Best regards,
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Alain it sounds like this may be another issue, since initially this was about the audio stream not working at all, while now it seems to work but with intermittent crashes. I think you should log a separate bug for this.

If I'm mistaking and this is the same issue as originally reported then you can leave it this way.
(Reporter)

Comment 25

4 years ago
Hi Florin,

You are not mistaking, but it was one of the issue that start happening with version 31.

Audio did not work - autostart did not work - Firefox crashed 

Now here is the situation with version 33 Beta :

Audio works (resolved) - autostart works (resolved) - Firefox crash (not solved) when navigating between radio stations. If I stay on the same station (same page - same player), it won't crash.

So, your decision, if you want me to open another big.

Best regards,
(Assignee)

Comment 26

4 years ago
(In reply to Florin Mezei, QA (:FlorinMezei) [on vacation - Sep 8-15 ] from comment #24)
> Alain it sounds like this may be another issue, since initially this was
> about the audio stream not working at all, while now it seems to work but
> with intermittent crashes. I think you should log a separate bug for this.

It doesn't appear to me to be the same issue (which was about sound not starting).
A new bug would be better IMHO.
OK, I reported this crash in bug 1067551 and will re-close this bug. Alain I asked in the new bug for crash signatures if you can provide them!  Thanks.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
This does not meet ESR landing criteria.
status-firefox-esr31: affected → wontfix
tracking-firefox-esr31: + → ---

Updated

3 years ago
No longer depends on: 1059456
You need to log in before you can comment on or make changes to this bug.