Enable e10s shims by default, even when browser.tabs.remote.autostart pref is false

RESOLVED FIXED in mozilla36

Status

()

Core
XPConnect
P2
normal
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: ally)

Tracking

unspecified
mozilla36
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm4+)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

4 years ago
The "File > Open e10s Window" menu item does not enable shims, so testers are reporting false positive bugs that are actually fixed when shims are enabled by browser.tabs.remote.autostart. I suggested that we just remove the "Open e10s Window" menu item in bug 1003313, but enabling shims all the time is better because shims will get more bake time (before we enable all of e10s) and casual testers can still try per-window e10s.

dom.compartment_per_addon (bug 1030420) to land first.
(Reporter)

Comment 1

4 years ago
Moving old M2 P2 bugs to M4.
(Reporter)

Updated

4 years ago
tracking-e10s: + → m4+
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
 https://tbpl.mozilla.org/?tree=Try&rev=1c5cfe8ad4c9

let's see what breaks test-wise
(Assignee)

Comment 3

4 years ago
Created attachment 8512087 [details] [diff] [review]
enableShimsByDefault

try looks green to jimm & I. billm?
Attachment #8512087 - Flags: review?(wmccloskey)
Comment on attachment 8512087 [details] [diff] [review]
enableShimsByDefault

OK, let's do this. However, could you please make it nightly-only? The compartment-per-addon stuff is nightly-only, so this should be too.
Attachment #8512087 - Flags: review?(wmccloskey)
(Assignee)

Comment 5

4 years ago
Created attachment 8512306 [details] [diff] [review]
enableShimsByDefault

once more, with ifdefs!
Attachment #8512087 - Attachment is obsolete: true
Attachment #8512306 - Flags: review?(wmccloskey)
Attachment #8512306 - Flags: review?(wmccloskey) → review+
(Assignee)

Comment 6

4 years ago
one of the perks of being a night owl today is that the trees are finally open!

  https://hg.mozilla.org/integration/fx-team/rev/8a1dfdaaeb3c
Not any more, I closed it because someone busted Android.

Backed out in https://hg.mozilla.org/integration/fx-team/rev/b0b2b78f2001 for making nearly every test suite on every flavor of Android time out in startup.
(Assignee)

Comment 8

4 years ago
(In reply to Phil Ringnalda (:philor) from comment #7)
> Not any more, I closed it because someone busted Android.
> 
> Backed out in https://hg.mozilla.org/integration/fx-team/rev/b0b2b78f2001
> for making nearly every test suite on every flavor of Android time out in
> startup.

Well that didn't last long. Try was green on android too
(Assignee)

Comment 9

4 years ago
okay, test ALL THE THINGS
remote: You can view the progress of your build at the following URL:
remote:   https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=c3ebccbfbc07
remote: Alternatively, view them on TBPL (soon to be deprecated):
remote:   https://tbpl.mozilla.org/?tree=Try&rev=c3ebccbfbc07
(Assignee)

Comment 10

4 years ago
I wonder if Bug 1091707 is the cause. Try for android is either green or timed out, no failure summmary.
The cause of your backout? No, the problem there was that when automation.py went to start up Fennec, either it never started, or started but never produced whatever it is that automation.py looks for to know that it successfully started the app.

The cause of your try run not getting Android builds? No, that's some signing server bustage, which someone should file a bug in Release Engineering about, but instead everyone is just retriggering the builds until they get a successful one.
Backed out for that android bustage: 

https://hg.mozilla.org/integration/fx-team/rev/a31d8d3703f8
Flags: needinfo?(ally)
(Assignee)

Comment 14

4 years ago
Created attachment 8515269 [details] [diff] [review]
enableShimsByDefault

version designed to not break android. please note that preprocessor.py does not fully support the macro syntax, so the guards are different in cpp and js.
Attachment #8512306 - Attachment is obsolete: true
Flags: needinfo?(ally)
(Assignee)

Comment 15

4 years ago
Created attachment 8515289 [details] [diff] [review]
enableShimsByDefault

thanks Tom
Attachment #8515269 - Attachment is obsolete: true
(Assignee)

Comment 16

4 years ago
remote:   https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=48272b5d82c6
remote: Alternatively, view them on TBPL (soon to be deprecated):
remote:   https://tbpl.mozilla.org/?tree=Try&rev=48272b5d82c6
(Assignee)

Comment 17

4 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/c6d53703d449

since try was green! \o/
https://hg.mozilla.org/mozilla-central/rev/c6d53703d449
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36

Updated

4 years ago
Depends on: 1095067
(Reporter)

Updated

4 years ago
Depends on: 1099416
Depends on: 1101182

Updated

2 years ago
Depends on: 1260945
You need to log in before you can comment on or make changes to this bug.