Closed Bug 1260945 Opened 4 years ago Closed 4 years ago

crash in XPCWrappedNativeScope::XPCWrappedNativeScope

Categories

(Core :: XPConnect, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox45 --- wontfix
firefox46 --- wontfix
firefox47 + wontfix
firefox48 + fixed
firefox-esr38 --- unaffected
firefox-esr45 - wontfix

People

(Reporter: alice0775, Assigned: billm)

References

Details

(Keywords: crash, reproducible)

Crash Data

Attachments

(3 files)

This bug was filed frrEMOVom the Socorro interface and is 
report bp-151479bb-b654-4b24-9660-97d952160331.
=============================================================

Reproducible : always

Steps To Reproduce:
1. Install "Remote XUL Manager"( https://addons.mozilla.org/en-US/firefox/addon/remote-xul-manager )
2. Open "Remote XUL Manager"'s option dialog from add-on manager
3. add "https://mozilla.org"(without " marks) and close the dialog
4. Optionally, Remove "Remote XUL Manager"

5. Install Flashblock( https://addons.mozilla.org/en-US/firefox/addon/flashblock/ ) and restart

6. Disable e10s and restart

7. Open https://advocacy.mozilla.org/encrypt/hybrid/4

Actual Results:
Browser crashes

Expected Results:
Not crash
Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=512c7e8f0030&tochange=a6b93cceaf4e

Regressed by: Bug 1185343
Blocks: 1185343
Has STR: --- → yes
Flags: needinfo?(michael)
Created attachment 8736535 [details]
permissions.sqlite

Instead of steps 1-4, you can use permissions.sqlite. copy it to user profile folder.
Attached file index.html
More simple STR:
1. Save attached html to local folder

2. Start Firefox
3. Create a boolean dom.allow_XUL_XBL_for_file = true in about:config
4. Install Flashblock ( https://addons.mozilla.org/en-US/firefox/addon/flashblock/ )
5. Disable E10s and restart

6. Open the saved local html

Actual Results:
Crash
(In reply to Alice0775 White from comment #4)
> Created attachment 8736590 [details]
> index.html
> 
> More simple STR:
> 1. Save attached html to local folder
> 
> 2. Start Firefox
> 3. Create a boolean dom.allow_XUL_XBL_for_file = true in about:config
> 4. Install Flashblock (
> https://addons.mozilla.org/en-US/firefox/addon/flashblock/ )
> 5. Disable E10s and restart
> 
> 6. Open the saved local html
> 
> Actual Results:
> Crash


Regression window:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=570921b6c566&tochange=c6d53703d449

Regressed by:c6d53703d449	Allison Naaktgeboren — Bug 1063156 - Enable e10s shims by default, even when browser.tabs.remote.autostart pref is false.r=billm
Blocks: 1063156
No longer blocks: 1185343
Flags: needinfo?(wmccloskey)
Flags: needinfo?(michael)
Flags: needinfo?(a.m.naaktgeboren)
Attached patch patchSplinter Review
I remember deciding that we wouldn't use compartment-per-addon for non-system compartments, and we have runtime assertions guaranteeing that. But it looks like I missed the check.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Flags: needinfo?(wmccloskey)
Attachment #8736933 - Flags: review?(bobbyholley)
Attachment #8736933 - Flags: review?(bobbyholley) → review+
[Tracking Requested - why for this release]: reproducible crash
https://hg.mozilla.org/mozilla-central/rev/b79de31a7a1b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Do you think this is worth uplifting at least to aurora? I don't see any crashes in 48 aurora in the last week with this signature but maybe this fix would catch other crashes as well.
Flags: needinfo?(wmccloskey)
It doesn't really seem worth it. If we're not hitting this crash, then nothing is going wrong. And it looks like we're not hitting it.
Flags: needinfo?(wmccloskey)
Flags: needinfo?(a.m.naaktgeboren)
You need to log in before you can comment on or make changes to this bug.