Closed Bug 1063161 Opened 6 years ago Closed 6 years ago

[Flame] Double notification displayed when trying to share a large video via sms

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
Linux
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: pensacola_m2000, Assigned: alive)

References

Details

Attachments

(1 file)

Gaia   a47ecb6368c015dd72148acde26413fd90ba3136
SourceStamp 757931d0149e
BuildID 20140904000203
Version 34.0a2
2.1 Aurora

Steps to reproduce:
1. Make sure you have a video on sd card or internal storage
2. Select the video and choose to share it via Messages.

Expected results:
Only one notification should be displayed, informing the user that the file is too large

Actual results:
Double notification displayed when trying to share a large video via sms.
First one is:
 " Messages
---------------------
The file you have selected is too large.

      OK"

and second one:
"Video
----------------
The file you have selected is too large.

      OK"

I expect to be displayed only one notification, not two.
Seems like it might be a bug in either messages or video?
Component: Gaia::System::Browser Chrome → Gaia::SMS
Hey Alive,

Looks like after patch for bug 927862 we have the issue described in comment 0:

1. SMS app is opened by Video app as inline activity;
2. SMS app calls "alert" and then leave activity with "postResult({ success: true })";
3. Two identical alerts is displayed. Except for the title, the first one is "Messages" and the second one is "Video", looks like the first is owned by SMS and second - by Video.

Is it something known?

Thanks!
Flags: needinfo?(alive)
I will take a look!
Assignee: nobody → alive
Component: Gaia::SMS → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
In bug 927862 we dropped the self_managed_event list in appWindow because it's not maintainable. It should be the event handler in sub module's duty to stop the propagation in order not to cause double handling.
Attachment #8486224 - Flags: review?(etienne)
[Blocking Requested - why for this release]:
Regression from bug 927862
blocking-b2g: --- → 2.1?
Comment on attachment 8486224 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23835

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
regression from bug 927862
[User impact] if declined:
If any inline activity call window.alert, there will be a redundant alert UI in the activity caller as well as activity callee
[Testing completed]:
yes by unit test
[Risk to taking this patch] (and alternatives if risky):
no
[String changes made]:
no
Attachment #8486224 - Flags: approval-gaia-v2.1?
master
https://github.com/mozilla-b2g/gaia/commit/47a2a9a2a3e3dd0ecee94fc76f1ea0febd2b3812
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Blocking, regression from bug 927862
blocking-b2g: 2.1? → 2.1+
Duplicate of this bug: 1063200
Attachment #8486224 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
This issue is verified fixed on both Flame 2.1, and Flame 2.2

If the user tries to share a video through MMS, they are only shown the "The file you have selected is too large." error 1 time. After selecting "OK" they are brought back to the video that was selected.

Flame 2.1

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.2

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.