Closed Bug 1064083 Opened 6 years ago Closed 5 years ago

Import (and pass) img/picture web platform tests

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: johns, Assigned: jdm)

References

()

Details

Attachments

(1 file)

https://github.com/w3c/web-platform-tests/pull/1234

As we land picture and update <img>, we should pull in the web platform tests where possible (and pass them).
It looks like we've already imported these tests but have most of them disabled: https://dxr.mozilla.org/mozilla-central/source/testing/web-platform/meta/html/semantics/embedded-content/the-img-element

I'd be happy to help get the ones that we do pass enabled, and ideally file bugs on the rest (if they don't already exist).

John, do you mind if I help out here?
(In reply to Mike Taylor [:miketaylr] from comment #1)
> It looks like we've already imported these tests but have most of them
> disabled:
> https://dxr.mozilla.org/mozilla-central/source/testing/web-platform/meta/
> html/semantics/embedded-content/the-img-element
> 
> I'd be happy to help get the ones that we do pass enabled, and ideally file
> bugs on the rest (if they don't already exist).
> 
> John, do you mind if I help out here?

Sure - we have bug 1139554 and bug 1139560 about some of these failures, it would be super helpful to go through the remaining ones and make sure they have bugs blocking this one.

I can help work on some of these as they come up, but have someone limited time recently
Assignee: john → nobody
Status: ASSIGNED → NEW
Depends on: 1139554, 1139560
Flags: needinfo?(john)
Cool, thanks. I'll have some time for this early next week.
Assignee: nobody → miket
I added a patch updating expectations for Bug 1139560. Once that lands, I'll update the expectations related to Bug 1139554 (I think I'll just get conflicts if I try before 1139560 lands) and then file bugs on the rest of the failures.
Yeah, this is a little messy--I wasn't sure what order all these related patches would land. It looks like bug 1139554 will land first, which means the WPT updates patch in 1139560 will be bit-rotted (but it's an easy rebase). So I'll upload a patch to 1139554 and update a rebased patch to 1139560, assuming they land in that order.

Does that make sense, Josh?
It does. Thanks!
Flags: needinfo?(josh)
Huh, I guess the srcset fixes broke that test. Odd that it didn't fail on my machine. The quick fix is to disable that test and file a bug for investigation. Filing now.
Actually I'll just point to this bug, the point of this bug is to figure out the rest of the failures and file meaningful bugs for them. We're not quite in meaningful territory yet.
Note to self: 

 0:11.93 TEST_END: Thread-TestrunnerManager-1 Harness OK. Subtests passed 80/89. Unexpected 1
<img src="data:,a" srcset="data:,b 10000x, data:,c 10000w" sizes="1px" data-expect="data:,b">
---------------------------------------------------------------------------------------------
Expected FAIL, got PASS

vs

12:46:38 INFO - TEST-UNEXPECTED-FAIL | /html/semantics/embedded-content/the-img-element/update-the-source-set.html | <img src="data:,a" srcset="data:,b 10000x, data:,c 10000w" sizes="1px" data-expect="data:,b"> - assert_equals: expected "data:,b" but got "data:,a"

The updated patch in Bug 1139560 disables this test and points back here. Once all the moving parts land, will investigate further.
Depends on: 1017878
Duplicate of this bug: 1023519
https://hg.mozilla.org/mozilla-central/rev/b8c0cfa633b4
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Assignee: miket → josh
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.